Q: Giant Bomb's podcasts suddenly stopped downloading with iTunes

Avatar image for maxxcanti
#1 Posted by MaxxCanti (124 posts) -

I'm subscribed to all of Giant Bomb's podcasts on iTunes, and they have suddenly stopped working.
I've tried changing versions, doesn't work with iTunes 10.7, 11.2, or 12.9.
I first noticed this on the 15th and it's still a problem. Anyone know what's up?


The "All Systems Goku" feed is also busted.

For the "Presents" feed I get the following iTunes error.

The other podcast feeds give this error.

Any ideas on how I can fix this?

Avatar image for amishmonster
#2 Posted by amishmonster (82 posts) -

I've been having the same issue, though instead of an error pop-up it just has the ! next to the feed name.

Avatar image for rorie
#3 Posted by Rorie (5880 posts) -

@amishmonster: @maxxcanti: I've seen a few other people with this issue but I don't think it's affecting everyone; have you tried unsubscribing and resubscribing?

Staff
Avatar image for amishmonster
#4 Posted by amishmonster (82 posts) -

@rorie No luck with that, I'm afraid. I've tried using the RSS link on the podcast episodes' pages, as well as pasting the URL from that link directly into iTunes, but it doesn't seem to recognize it as a thing to subscribe to (instead of the name of the podcast it displays the URL and can't download anything).

I'm using iTunes 10.7 as well, so I'm not sure if that's contributing to the problem, but it was fine until last week. Thanks for looking into it!

Avatar image for rorie
#5 Posted by Rorie (5880 posts) -

@amishmonster: Hmm, can you try logging out and back in and trying to subscribe to the basic RSS feed (non-Premium)? The only thing I can think of is that you might have had your API key overwhelmed for some reason. Sorry for the trouble!

Staff
Avatar image for amishmonster
#6 Posted by amishmonster (82 posts) -

No dice with logging out/in, restarting my browser and computer, or ctrl-f5ing the page. I can't subscribe to the non-premium feeds either (through the iTunes store or the RSS link from here on the site). I subbed to a couple other podcasts through iTunes as a test, and they appear to work normally, as do the other ones I was already subscribed to. How bizarre!

I can listen to them through the website, so it's not a big deal, just a convenience thing.

Avatar image for fisk0
#7 Edited by fisk0 (6953 posts) -

I've had this since last friday too (starting with last week's beastcast), pretty sure it's an issue with dts.podtrac.com which all the downloads go through, presumably to get listener statistics?

Moderator
Avatar image for captaininvictus
#8 Posted by CaptainInvictus (250 posts) -

This has also been affecting me. I'd love to fix it, I've been manually downloading the podcasts since and it sucks, plus they don't remember listening spots when downloaded that way.

Avatar image for maxxcanti
#9 Posted by MaxxCanti (124 posts) -

@amishmonster: Clicking the "!" will give you the error message.

And the tips in here haven't worked yet. :/

Avatar image for rorie
#10 Posted by Rorie (5880 posts) -

Sorry for the lack of progress here; I've filed a ticket last week and hopefully someone will be able to figure this out soon. It isn't affecting everyone that uses iTunes, so hopefully there's some kind of common thread between your accounts that is causing this. Sorry for the trouble!

Staff
Avatar image for monkeyman1138
#11 Posted by Monkeyman1138 (2 posts) -

Same issue here.