Q: Giant Bomb's podcasts suddenly stopped downloading with iTunes

  • 56 results
  • 1
  • 2
Avatar image for fisk0
fisk0

7073

Forum Posts

58376

Wiki Points

0

Followers

Reviews: 0

User Lists: 72

#51  Edited By fisk0  Moderator

@monkeyman1138: Do you also happen to have to use a 32-bit version of iTunes? I saw you saying you also use 12.1.3.6 which is their final 32-bit version. I'm starting to think this may be some kind of SSL/TLS version problem, where that version can't handle current https encryption anymore? The iTunes version is from 2015 after all, and the most recent version of TLS, 1.3, seems to be from 2018, so it may not support that.

Still find it really weird that a current version of Google Play Music can't download the podcast either, but if we both use the same version of iTunes and have that problem, that may at least be part of the problem.

Avatar image for monkeyman1138
Monkeyman1138

19

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Yes that is the version I use.

Avatar image for monkeyman1138
Monkeyman1138

19

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Avatar image for monkeyman1138
Monkeyman1138

19

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Another bump, another reminder that this is still an issue, I hate to nag, but as a premium subscriber am getting very frustrated, particuarly as it doesn't seem like "Will" (I assume the tech guy) has even looked into it yet.

Avatar image for rorie
rorie

6342

Forum Posts

1144

Wiki Points

0

Followers

Reviews: 1

User Lists: 3

#55  Edited By rorie  Staff

Another bump, another reminder that this is still an issue, I hate to nag, but as a premium subscriber am getting very frustrated, particuarly as it doesn't seem like "Will" (I assume the tech guy) has even looked into it yet.

Hey, apologies for the slow progress on this, but I've re-pinged Will to look into now that we know it's restricted to the older iTunes versions. I can't guarantee that we'll be able to fix it if it's a security issue that's unsupported in the older iTunes, but hopefully he'll be able to say for sure.

Avatar image for rorie
rorie

6342

Forum Posts

1144

Wiki Points

0

Followers

Reviews: 1

User Lists: 3

#56 rorie  Staff

According to Will this is a limitation of that version of iTunes unfortunately and won't be something we'll be able to resolve:

This is most likely because of the tls version 1.2 limitations. Old versions of itunes cannot process requests made via tls 1.0. For security reasons we have disabled tls 1.0.

Security experts recommend disabling TLS 1.0: https://docs.microsoft.com/en-us/security/solving-tls1-problem

Unfortunately we will not be able to fix this issue as tls 1.2 is a requirement for us