Avatar image for itafroma
#1 Posted by itafroma (23 posts) -

Before today, all of the RSS feeds had specific titles (e.g., "Quick Looks", "Unfinished", "Subscriber"), but it appears they've all been reset to "Giant Bomb - Videos", making it difficult to tell them apart in my podcast viewer.

Additionally, the Quick Look RSS feed is lagging behind by a few hours: The Last of Us Remastered showed up about an hour ago, and Halfway hasn't shown up yet at all.

Avatar image for nhlmaniac
#2 Posted by NHLmaniac (136 posts) -

Yes, this is also happening to me.

Avatar image for laika
#3 Posted by laika (148 posts) -

The RSS feed generator was just rewritten, which probably caused this regression. We'll take a look!

Avatar image for nhlmaniac
#4 Posted by NHLmaniac (136 posts) -

Still no new videos in any of the feeds today.

Avatar image for laika
#5 Posted by laika (148 posts) -

There's a different bug with RSS caching that I think @edgework is looking in to. Sorry for the inconvenience.

Avatar image for splodge
#6 Posted by Splodge (2753 posts) -

Ah was wondering why the unfinished QL wasnt out yet.

Avatar image for rick
#7 Edited by rick (506 posts) -

@itafroma: @nhlmaniac:

The lag is a feature, not a bug. The thing is that feature has a bug.

How's that for double-speak? I'm not 100% sure of what the intention is for the new feed cache and the guy who wrote it -cough- @frobie -cough- did a code and bail so I can't ask him (he's on vacation now).

Try adding ?nocache to the url and let me know if the results are more in line with what you expect. Oh and don't ALWAYS use nocache please!

Avatar image for rick
#8 Posted by rick (506 posts) -

@itafroma: I do know the cause of the titles all being the same but don't know why it was changed. Is that a major problem? Sorry for the ignorance, the RSS stuff has been a black box to me until recently.

Avatar image for itafroma
#9 Edited by itafroma (23 posts) -

@edgework ?nocache doesn't help: the Quick Look feed still stops at The Last of Us Remastered with or without it.

The changes to the feeds are an inconvenience, bordering on an annoyance. Not sure I'd say it's a major problem if the feeds do get fixed and start showing new things. My GB-watching flow has been to pipe the feeds automatically into iTunes so I can watch them in full HD and 60fps glory on my TV via Apple TV while I work, and it's nice to know what's available without having to click through to each feed to figure out which feed is which, and it's also nice to watch stuff as it comes in. For the past couple of days I've had to check the site periodically, manually download the video, then manually add it to my library before I can watch it.

You mentioned that (at least when it's working right) the lag is intentional, but also that it's a feed cache: is it actually a delay, where things will always appear N minutes/hours after it is published on the live site, or is it cached in the sense that the feed gets updated at a set schedule (like every 3 hours)/won't update for a certain period of time after I pull it once?

Avatar image for nhlmaniac
#10 Posted by NHLmaniac (136 posts) -

Looks like all the feeds are caught up now. All the recent stuff that was missing is downloading for me right now in iTunes. Still looks like the names of the feeds are still just Giant Bomb - Videos though.

Avatar image for rick
#11 Posted by rick (506 posts) -

@itafroma: Yeah, it turns out that the feed you're talking about wasn't part of the rewrite. The issue was something else only tangentially related to RSS feeds and MrPibb fixed it.

Avatar image for itafroma
#12 Edited by itafroma (23 posts) -

Everything's updating here, too. Rad, thanks!

Avatar image for itafroma
#13 Posted by itafroma (23 posts) -

Spoke too soon. The Quick Look feed is updating on schedule, but the Unfinished feed is lagging behind now. ?nocache doesn't seem to help there, either.

Avatar image for nhlmaniac
#14 Posted by NHLmaniac (136 posts) -

Yep, Lovely Planet Quick Look and the Unfinished from this morning are not on the feeds yet.

Avatar image for not_much_chop
#15 Edited by NOT_MUCH_CHOP (36 posts) -

Having the same problem. Feeds are all called 'videos' and haven't updated since the 1st, 3 days ago. So no Unprofessional Fridays and the last QL was Lovely planet. I miss my feeds : (

Avatar image for nhlmaniac
#16 Posted by NHLmaniac (136 posts) -

Yeah The Quick Look feed seemed to briefly update sometime Friday night, so I got the Lovely Planet and Wii Sports Quick Looks downloaded, but all the rest are broken again.

Avatar image for itafroma
#17 Posted by itafroma (23 posts) -

All the feeds seem to be working again for me here.

Avatar image for nhlmaniac
#18 Edited by NHLmaniac (136 posts) -

Yep, working for me again too, the only thing not fixed is the titles for the feeds, they are all still listed as "Giantbomb Videos"

Avatar image for itafroma
#19 Posted by itafroma (23 posts) -

Quick Look feed is broken again. Starting to think the intentional lag @edgework mentioned does exist, and that it's set to 2 days. :(

Avatar image for unshaven
#20 Posted by unshaven (10 posts) -

Yeah, the last I have in my QL feed Wii Sports Club.

Avatar image for nhlmaniac
#21 Posted by NHLmaniac (136 posts) -

Yep. Still broken. I noticed however that the video buddy app is working normally and I can downloaded the videos there. Is that a different set of feeds?

Avatar image for not_much_chop
#22 Edited by NOT_MUCH_CHOP (36 posts) -

Yeah it's the same for me. Getting frustrating.

Avatar image for itafroma
#23 Posted by itafroma (23 posts) -

Quick Look feed updated to Eidolon sometime last night. The other segmented feeds seem to be suffering the same problem as Quick Look: they don't update for a couple of days, then catch up.

I was getting up-to-date videos on the All Videos feed, but that seems to have stopped this morning as well: the latest Unfinished is missing from it.

Avatar image for jam_enslaver
#24 Posted by Jam_Enslaver (31 posts) -

I'm still not seeing updates to the feeds on SD quality. Last Subscriber video is 30 Day Trial: World of Warcraft - Part 02, last QL is Wii Sports Club, last Unfinished is Undead Overlord: 07/31/2014.

Avatar image for itafroma
#25 Posted by itafroma (23 posts) -

Maybe I shouldn't jinx it, but the feeds all seem to have been working as expected (save them all being called "Giant Bomb - Videos") for the past day or so.

Avatar image for nhlmaniac
#26 Posted by NHLmaniac (136 posts) -

Still seems to be some sort of delay. The Mount Your Friends QL is has been up on the site for 3 hours, but is still not on any of the feeds? Is the delay intentional? Again whatever feed the video buddy app is using is up to date, where can I subscribe to that feed? This is getting annoying, but late videos is better than no videos.

Avatar image for laika
#27 Posted by laika (148 posts) -

Still seems to be some sort of delay. The Mount Your Friends QL is has been up on the site for 3 hours, but is still not on any of the feeds? Is the delay intentional? Again whatever feed the video buddy app is using is up to date, where can I subscribe to that feed? This is getting annoying, but late videos is better than no videos.

That app uses the API. You can find details at http://www.giantbomb.com/api.

Avatar image for nhlmaniac
#28 Posted by NHLmaniac (136 posts) -

@laika: Yeah i know that it uses the API, but my point is that something that someone else made is working better and more reliably than what subscribers are paying for. Why is that working correctly but not the feeds? Just a little annoyed that it took 9 days for another staff member to reply to this topic, but thank you for your response.

Avatar image for baltimore
#29 Posted by Baltimore (390 posts) -

Was working fine in Itunes until yesterday morning. Getting titles but now no longer updating.

Avatar image for nhlmaniac
#30 Posted by NHLmaniac (136 posts) -

Seems like only the Quick Look feed is behind still. Morning show and WoW videos downloaded in the Features and Subscriber feed though.

Avatar image for nhlmaniac
#31 Posted by NHLmaniac (136 posts) -

So is anyone even trying to fix this anymore?

Avatar image for not_much_chop
#32 Posted by NOT_MUCH_CHOP (36 posts) -

Yeah my last ql is Back to Bed on Saturday! Please let us know if its being worked on or if its something we have to put up with from now on.

Avatar image for mrpibb
#33 Posted by mrpibb (480 posts) -

sorry guys, continuing to look into it, it's been a bit hard to diagnose as our stage and dev boxes don't show the issues.

Avatar image for nhlmaniac
#34 Edited by NHLmaniac (136 posts) -

@mrpibb:

This is the feed I put into iTunes. If you load it in chrome you can see that the last quick look it has updated for was the Back to Bed Quick Look from Saturday.

http://www.giantbomb.com/videos/feed/hd/3/

The All Videos feed however, is updating normally.

http://www.giantbomb.com/videos/feed/hd/

Avatar image for nhlmaniac
#35 Posted by NHLmaniac (136 posts) -

Came home today and all the videos that were missing have downloaded in iTunes. Looks like the feed names have been fixed too. Will update tomorrow to see if the videos post on time once again or if there still is a delay.

Avatar image for not_much_chop
#36 Posted by NOT_MUCH_CHOP (36 posts) -

The Quick Look feed seems a-ok, but i tried the Subscriber and Unfinished feeds and they still are named 'Giant Bomb - video'.

Avatar image for itafroma
#37 Posted by itafroma (23 posts) -

All the feeds are named correctly and Unfinished updated immediately this morning, yay! We'll see if Quick Looks updates in 2 hours.

@not_much_chop I think it might be caching issue in your podcast viewer: the feeds all have the correct names in the actual XML. iTunes updated most of the feed names for me, but is still holding onto the old TANG feed name.

Avatar image for itafroma
#38 Posted by itafroma (23 posts) -

Quick Look feed updated promptly after 9am. Rad.

Avatar image for nhlmaniac
#39 Posted by NHLmaniac (136 posts) -

Looks like everything is fixed, thanks guys. Although I am getting asked to reenter my password a lot more frequently then usual when the feeds check for updates. Not sure if this is an issue with iTunes, or the feeds.

Avatar image for tsigo
#40 Edited by tsigo (125 posts) -

Bump. Subscriber feed is missing videos now.

Edit: Looks like it's just the last episode of Demo Derby that isn't showing up.