Avatar image for mets86fan
#1 Posted by mets86fan (3 posts) -

When trying to watch a video I am met with the “loading video” image while it is supposedly trying to load. However, I found that if I switch over to a different tab and come back the video instantly loads. Not sure why this would happen. Any help is greatly appreciated.

Avatar image for mets86fan
#2 Posted by mets86fan (3 posts) -

https://imgur.com/a/pKfbxpX

Here’s a screen cap of what’s happening.

Avatar image for mrfluke
#3 Posted by mrfluke (6068 posts) -

Yep been having this same issue lately, and even during live-streams as well

I also found that if I put the phone to sleep and wake it up the video instantly loads

Avatar image for klynn
#4 Posted by Klynn (48 posts) -

I've found if I hit pause then play again it usually just goes instantly. Still annoying but easier than changing tabs.

Avatar image for damoo
#5 Posted by DaMoo (60 posts) -

I have a similar issue. I am stuck on "Loading..." when attempting to play both pre-recorded and live videos in Safari on iOS 12. However if I hold the refresh button down and hit "Request Desktop Site", the videos will load and play. I don't have this issue in Firefox on iOS.

Seaparate but related issue, I used to be able to play videos without full screening so I could watch while also seeing chat. But now I can't do that, the video pauses in the web page and I have to fill screen it for the video to play. I don't think Apple removed the functionality to play a video in the webpage as it works with other websites like the YouTube mobile site.

Avatar image for pants
#6 Posted by pants (128 posts) -

Chrome and Safari on iOS both use the same Apple-mandated browser codebase, and iOS 12's version of it broke a bunch of stuff, including some really basic javascript functionality, like reversing the contents of an array. I suspect this bug on the player will get fixed when iOS 12.1 comes out.

Avatar image for spareburden
#7 Posted by spareburden (7 posts) -

Hey guys. Is anyone still having this issue? I got a new iPad today running a fresh install of iOS 12.1 (no backup restore) and this is happening. The “open a new tab and close” trick works though.

Avatar image for nigeth
#8 Posted by Nigeth (159 posts) -

Can't watch anything on the site anymore because of this bug and switching of tabs or other tricks don't work. iPad Pro on iOS 12.

If it weren't for the inofficial app I wouldn't be able to watch asnything. Couldn't even watch the die another friday livestream.

Avatar image for mostman
#9 Posted by mostman (346 posts) -

Same problem here.

Avatar image for kiddomac
#10 Posted by KiddoMac (52 posts) -

Same here,

New iPad Pro 2018 with the latest non-beta iOS 12.1. I can get the videos to load with the tricks mentioned in these forums (switch to another tab and back, and/or play-pause video) but I find this unacceptable for a video-site.

Avatar image for ylor
#11 Edited by Ylor (1 posts) -

+1. Same issue.

Avatar image for shades846
#12 Posted by shades846 (230 posts) -

Are people having issues with live streams on iOS 12.1 using safari just playing for a few mins then going back to start of the live stream ?