Avatar image for bollard
#1 Posted by Bollard (8151 posts) -

I've lost count of the number of posts I've lost to a "Flagrant System Error" recently, but I've finally realised it's because the Tab-Space method of replying to a thread is at fault. Here's some pictures:

Note the white box (using Chrome on Linux), this is because I pressed tab after typing to move the selected item to
Note the white box (using Chrome on Linux), this is because I pressed tab after typing to move the selected item to "Post Reply" but it actually has selected some invisible UI element. Pressing space has then tried to activate this invisible button, instead of posting my reply as I expected.
When I then manually click
When I then manually click "Post Reply" or press tab and space one more time it tries to post, resulting in the Flagrant system error.

TL;DR: If you press tab and then space when trying to post a reply to a thread, while the cursor is in the reply box, it moves to some invisible UI element and presses that instead of the reply button. This causes a flagrant system error 100% of the time, which also deletes your whole reply (nice).

Avatar image for wcarle
#2 Posted by wcarle (375 posts) -

@bollard: Sorry about that, that's a nasty bug.

Thanks for all the debugging help! We'll look at this ASAP.

Staff
Avatar image for bollard
#3 Posted by Bollard (8151 posts) -

@wcarle: No worries, and thanks for looking in to it! I hope the instructions were clear enough.

Avatar image for wcarle
#4 Posted by wcarle (375 posts) -
Staff
Avatar image for bollard
#5 Posted by Bollard (8151 posts) -

@wcarle: Fantastic! Just tested and it worked great :)

Avatar image for oursin_360
#6 Edited by OurSin_360 (6133 posts) -

hmmm

*edit* tried to recreate it but failed, i've had that error before too