Avatar image for demoskinos
#1 Posted by Demoskinos (17325 posts) -

So I don't know why but all of a sudden loading giantbomb up on my phone results in the site just not responding and being as snappy as it should be. I'll try to scroll up and down on the forums and the screen will just not scroll at a normal speed. Now, I would just chalk this up to my phone being garbage but I've loaded dozens of other sites and tested other things on my phone and they are all still responsive. Its just when I load up Giantbomb and/or ComicVine that I'm getting this unresponsiveness when attempting to scroll pages.

Not sure what it could be I've already tried clearing the browser cache/cookies etc. If it helps I'm on an HTC Trophy running Windows 7 ver. 7.10.8107.79

Avatar image for beachthunder
#2 Posted by BeachThunder (14580 posts) -

Also, it's not working properly on 3DS anymore. The site only takes up the screen space of the bottom 3DS screen instead of filling up the space of both screens.

Avatar image for demoskinos
#3 Posted by Demoskinos (17325 posts) -

@beachthunder: Yeah I was getting a bunch of 500 errors for a spell yesterday which made me wonder if they were tinkering with the site in the back end or something yesterday. I've never had problems on mobile before.

Avatar image for nail1080
#4 Edited by nail1080 (2025 posts) -

ironically the site worked much better on my phone before the mobile specific site was made, but now it's such a slow mess of shit that I don't bother anymore

Avatar image for toowalrus
#5 Edited by TooWalrus (13391 posts) -

It's really super super snappy on my iPhone, wish I could reply to comments, though. I'd swap flagging for quoting any day..

Avatar image for alexw00d
#6 Edited by AlexW00d (7479 posts) -

Alexis tweeted last night that he implemented some iPhone scrolling thing, and in doing so it seems he broke it for the rest of us.

I'd tag him in this post but you can't do that on phone.

Avatar image for alexisg
#7 Posted by alexisg (413 posts) -

Fix for non iphone people and scrolling is going to be deployed soon. Seems some mobile phones can't deal with overflow: scroll on a div. Which is like css 101 but not suprising. Sorry for that. Will be fixed momentarily.

Yeah the quoting and reply thing is a bummer and I'd like to get that fixed soon but it takes some work because of all the crazy html, embeds etc that gets injected into most people's comments. At the very least I'd like reply to work.

Avatar image for demoskinos
#8 Posted by Demoskinos (17325 posts) -

@alexisg: So I hate to even make this an issue again cause I feel like I'm being a bit whiny and like one of 5 people on here that use a Windows phone but whatever update was pushed now causes the site to only render the top half of the page meaning I can't scroll or use the site at all in mobile at the moment.

Avatar image for lordandrew
#9 Edited by LordAndrew (14601 posts) -
No Caption Provided

This is probably related to this bug or its fix.

There's those ugly bars at the right and bottom with a tiny bit at the top as well, the page screws up if you open the side drawer forcing a refresh, the location bar never auto-hides, and the scrolling feels wrong and lacks any overscroll effect.

If I switch to Chrome or Firefox, the layout issues are fixed but the scrolling still feels wrong. In fact, the current Chrome beta handles it worse than the stable version of Chrome, with link highlight remaining in place while the content scrolls.

The Firefox nightlies and Chrome beta also support automatic hiding of the address bar, and as with the stock browser it does not work with Giant Bomb.

Avatar image for alexisg
#10 Edited by alexisg (413 posts) -

@Demoskinos apologies for the bug on windows. I am in NY till Tuesday but will get this fixed as soon as I can. I have someone else looking at the problem but some of this stuff gets super tricky so I probably need to take a hard look at it.

@LordAndrew I may ping you directly next week.

Avatar image for demoskinos
#11 Posted by Demoskinos (17325 posts) -

@alexisg: I gotcha man thanks for caring enough to take another look at it. Just a bit of a bummer since I always check the forums at work when I'm on break.

Avatar image for rachelepithet
#12 Posted by rachelepithet (1646 posts) -

The only problem I've noticed happening this past week on iOS safari/chrome is that the iPhone "tap the Network-Time-Batterylife bar at the top of the screen to auto scroll back to the address bar" ability stopped working. And only on GB.

Avatar image for truthtellah
#13 Posted by TruthTellah (9809 posts) -

I'm glad I'm not the only one having issues with it for the last few days. It was working fine before whatever last update, but now the mobile site is basically unusable on the Galaxy SII. It looks like LordAndrew's screenshot, and when you scroll down, everything shakes back and forth like the page is having a seizure. Hopefully the next update will address it, as I usually like using the mobile site.

(I can take a video of it if that would help)

Avatar image for jjweatherman
#14 Posted by JJWeatherman (14929 posts) -

Yeah, I can't scroll at all on Windows Phone as of a couple of days ago. Or maybe it really is only rendering the top section of the pages. Either way, it's very much broken.

Avatar image for demoskinos
#15 Posted by Demoskinos (17325 posts) -

@jjweatherman: It was rendering really slowly but yeah now it straight up only renders the top half of the page and doesn't let you scroll any further.

Avatar image for truthtellah
#16 Edited by TruthTellah (9809 posts) -

Does it wig out for yall when you -can- get it to scroll? Despite loading everything(with a white space on the side and bottom), it starts doing the Harlem Shake whenever I scroll a bit. It is... unpleasant.

Avatar image for autobarn
#17 Posted by AutoBarn (107 posts) -

Same for me. Site won't scroll at all.

Avatar image for newhaap
#18 Posted by newhaap (484 posts) -

I have the same problem also. I can scroll a bit (just down to the GiantBomb header so not much at all) whenever the search bar is showing. And I can scroll on the News page although that page doesn't seem to shrink to fit my screen.

Avatar image for truthtellah
#19 Posted by TruthTellah (9809 posts) -

@alexisg: Any word on when the mobile site might be fixed following the update that broke it? Could it not just get rolled back temporarily until a full fix is figured out?

Thanks! :)

Avatar image for brodehouse
#20 Posted by Brodehouse (10827 posts) -

On iphone the main problem I have is that the text entry box for replies and even the Add Reply button itself just don't work 50% of the time.

Avatar image for alexisg
#21 Edited by alexisg (413 posts) -

I'll be back in the office today. Was out on a mini vacation. First thing I will look at.

Avatar image for truthtellah
#22 Edited by TruthTellah (9809 posts) -

Thanks! Look forward to being able to use the mobile site again.

Avatar image for truthtellah
#23 Posted by TruthTellah (9809 posts) -

@alexisg: Looks like you perhaps fixed it! (on Galaxy S2) Good stuff.

Avatar image for demoskinos
#24 Posted by Demoskinos (17325 posts) -

@alexisg: Looks like you perhaps fixed it! (on Galaxy S2) Good stuff.

Indeed. Fixed for me too. Thanks Alexis! =)

Avatar image for villainy
#25 Posted by villainy (802 posts) -

@demoskinos: I've basically been waiting for you to give the all clear before I tried again. Working on my Lumia too! Thanks Alexis!

Avatar image for alexisg
#26 Posted by alexisg (413 posts) -

Great to hear. I forget at what time the fix went out (I was in meetings a ton this afternoon). @lordandrew: Can you tell me if your issues are fixed? I am testing on a Nexus and using the Android SDK emulator (which is dog slow) and seems like things look pretty good. I'll have the rest of the staff check their phones as well but hopefully most things are fixed.

Avatar image for brendan
#27 Posted by Brendan (9040 posts) -

My scrolling gets caught on videos and won't scroll past them. Its good to hear that the overall scrolling is being worked on. One other problem for me is with overall video playback, which is really slow.

Avatar image for lordandrew
#28 Posted by LordAndrew (14601 posts) -

@alexisg Yep, it appears to be working well again. Thanks.

Avatar image for truthtellah
#29 Posted by TruthTellah (9809 posts) -

@brendan said:

My scrolling gets caught on videos and won't scroll past them. Its good to hear that the overall scrolling is being worked on. One other problem for me is with overall video playback, which is really slow.

Ah yes, I still have this issue, as well, but for the most part, the mobile site is back to being functional. Hurray!

Avatar image for zero_
#30 Posted by Zero_ (2039 posts) -

I have issues scrolling down past some images and videos.

Avatar image for solh0und
#31 Posted by Solh0und (2045 posts) -

@zero_ said:

I have issues scrolling down past some images and videos.

I,too also have this same issue.