Unable to view website on Pixel 3XL Chrome

Avatar image for dareitus
#1 Posted by Dareitus (17 posts) -

As title says, the website completely fails to load on Pixel 3XL Chrome (Android).

I have had it work once in the past 3-4 days but then it went back to not loading at all as if the website is down. Works fine over same network on other devices. Phone fails if on Wi-Fi or LTE.

Very rarely it will load a non-functional version of the site with GB logos repeating at the top left of the website and bits of broken text on white background.

Pixel 3 XL is updated to latest version of Android as is the Chrome App.
I have attempted deleting all my cookies and settings related to giantbomb.com to no avail.
I have not tried another mobile browser because effort.

Avatar image for dareitus
#2 Posted by Dareitus (17 posts) -

Attempting to connect to specific pages (IE the new ranking of fighters video) via direct link fails as well. All other websites work on the phone.

Avatar image for dareitus
#3 Posted by Dareitus (17 posts) -

More updates:
Installed Firefox for Android - Giantbomb is still the only website that doesn't work on the phone.
Doesn't work over WiFi or LTE connection, browser just says the website is down.

Avatar image for rorie
#4 Posted by Rorie (5921 posts) -

@dareitus: Hmm, I'm on a 3AXL and it's working fine here. Is there a setting to flush your cache on your mobile browser? It's possible your ISP is blocking the site somehow? Does gamespot.com work?

Staff
Avatar image for dareitus
#5 Posted by Dareitus (17 posts) -

Done a bit more trouble shooting on it. My work Wi-Fi comes from Verizon LTE and my phone is Verizon LTE. Original problems still persist on those two networks but goes away on my home Wi-Fi (Comcast).

Also, repeatedly refreshing the page over and over will usually get it to load within 20 attempts. Can watch one video before it breaks again.

Checking gamespot.com appears to work fine.

Avatar image for dareitus
#6 Posted by Dareitus (17 posts) -

@rorie as far as I can tell, problem only occurs in Verizon LTE and can be resolved through repeated hard-refreshing. Not sure what would cause that but at least I can stream at work again.

Avatar image for dareitus
#7 Posted by Dareitus (17 posts) -

Although, my PC on the same Verizon LTE Hotspot can access the website fine. It seems to be specifically related to my phone accessing the site over LTE

Avatar image for dareitus
#8 Posted by Dareitus (17 posts) -

ERR_CONNECTION_CLOSED

ERR_CONNECTION_RESET