Why Can't I Download Video? (or) Where's My Videos?

Avatar image for rick
#1 Edited by rick (506 posts) -

If you tried to download a video or play a video on your phone, tablet or set top box and got an error video instead there's a few possible reasons for that.

  1. You're downloading from a valid link but
    1. You're not logged in to Giant Bomb
    2. The video is premium and
      1. Your subscription expired
      2. You never had a subscription
  2. You're using an app on your phone/tablet/set top box and
    1. You haven't linked your Giant Bomb account
    2. The developer no longer supports it
    3. You haven't updated it
    4. We've never heard of this app and the developer never told us about it
  3. You're using a generic app that uses our RSS feed to get the videos
  4. You're running a homebrew script that needs some tweaking
  5. You're using iTunes
  6. You're using a downloader like jDownloader that mangles the video links
  7. You're on a LG Android device and are using the default media player
  8. You're running a browser on something that isn't a desktop, laptop, phone or tablet (e.g. Playstation, XBox, etc.) and you've chosen a video quality other than Auto.
  9. You're on an older Android device that doesn't support HLS
  10. There's a use case our developers didn't think about

If its 1, Log in to your premium account or why not renew or subscribe?

If its 2, If you're using Video Buddy you will need to Log In and link your Giant Bomb account before you can watch any video. If you're using some other app and are having problems please let us know which app that might be. Definitely make sure you have the latest version of the app. You might also checkout these apps

Giant Bomb Video Buddy Android or iOS

Giant Bomb Apple TV App

If its 3 or 4, You're going to need to append your API key to the video url or the RSS feed like this:

http://v.giantbomb.com/video.mp4?api_key=aaabbb111

http://www.giantbomb.com/videos/feed/hd/?api_key=aaabbb111

For some (many) podcast apps you will need to add your userid/password too and use https.

https://user:pass@www.giantbomb.com/videos/feed/mobile/?api_key=aaabbb111

We're going to look into changing this so the user and password aren't necessary

Don't have an api key? Click Here

Please note, you'll be limited to 20 unique video downloads a day downloaded this way.

Also if you're using wget/curl in your homebrew script you will need to provide a unique user agent. wget/curl requests with empty or default user agents are blocked at the firewall.

If its 5, iTunes is being stupid (shocker) and considering urls that don't end in .mp4 to be valid

If its 6, It seems jDownloader and other downloaders are not including the api_key parameter in the URL. This is now a required thing and cannot be changed. All off-site video downloads require some kind of authentication. If the downloader can't or won't append the api_key parameter there's nothing we can do to support it. This sucks, yes. We're sorry.

GiantBomb User @smek seems to have found a solution for jDownloader.

If its 7, The default media player on most LG devices has a nasty bug in it that causes us (and other video/podcast producers) major headaches. We are specifically blocking that player. Its something we hate to do but the damage it does to us lead us to taking this action. Getting in contact with a huge Chinese hardware manufacturer to discuss this issue is impossible.

Good old VLC player works like a charm.

If its 8, This is our problem, we should never have given you those options on those devices because now they just won't work and before they worked for you but were bad for us. We'll remove those options on those devices so there's no more confusion.

If its 9, We're sorry. Some Android devices can no longer play our videos at all. This would be any device that doesn't support HLS. For the most part any Android before 3.0 will not support HLS and some very low end devices cannot either. Android 4.0 isn't very good with HLS either. We have to drop support for those devices.

If its 10, Sorry! No one's perfect. Let us know about it and please also include some info about the video and where you're trying to watch from.

Avatar image for shrekeh
#2 Edited by Shrekeh (58 posts) -

I'm having issues downloading videos in that when I right click and save as on HD/High etc it just gives me a HTML link to download. Was not happening a few hours ago. This is for Persona 4 endurance run vids. I just tried to download the latest Trackmania quicklook and that was fine, so something to look into?

Avatar image for iqmay
#3 Edited by iqmay (7 posts) -

I'm getting the error message video while watching videos on my Apple TV 4, using the Giant Bomb app, tested it with a few videos, none of them worked.

Re-linking my account on the settings page didn't help.

Avatar image for amyggen
#4 Edited by AMyggen (7738 posts) -

Getting the error when I try to watch videos in Progressive and HTML5 on my PC, newest version of Chrome. Streaming seems to work for now.

Trying to watch the newest UPF.

Avatar image for morello
#5 Edited by Morello (123 posts) -

Having the lovely error video play while using the Plex Giant Bomb channel to try and watch Metal Gear Scanlon 5 premium videos. API key is set in the options.

Edit: also from the Giant Bomb Video Buddy android app.

Avatar image for darth_furder
#6 Edited by darth_furder (37 posts) -

Getting issues and error message while trying to finish up UPF on roku. I know it's an old app from the Whiskey hay days, but I didn't have issues before.

Avatar image for bassman2112
#7 Edited by bassman2112 (1201 posts) -

Been getting the error message on Firefox, PC, HTML5 set to High on all videos (not just premium)

Avatar image for noremnants
#8 Edited by NoRemnants (439 posts) -

Same here. Error video when trying to watch HTML 5 videos on the website using Chrome/OS X.

@amyggen said:

Getting the error when I try to watch videos in Progressive and HTML5 on my PC, newest version of Chrome. Streaming seems to work for now.

Avatar image for aera
#9 Edited by aera (7 posts) -

I'm getting this when I try and download the TrackMania Turbo Quick Look (http://www.giantbomb.com/videos/quick-look-trackmania-turbo/2300-11061/) via the normal website; tried logging out and in again to no effect.

Avatar image for thewyattshield
#10 Edited by Thewyattshield (7 posts) -

I'm getting the error video no int he iOS video buddy for every video no matter the quality.

Avatar image for canadiantoastzombie
#11 Edited by canadiantoastzombie (329 posts) -

On Chrome Canary.

Progressive and HTML5 doesn't work for any videos (premium or non premium) but streaming does.

Avatar image for scottish_sin
#12 Edited by Scottish_Sin (247 posts) -

I'm getting the error message while using HTML5 on my PC, and I'm using the newest version of Chrome.

Avatar image for anuiran
#13 Edited by Anuiran (19 posts) -

I can't even listen to the podcast....

Avatar image for morello
#14 Edited by Morello (123 posts) -

Also same error video when using Chrome watching MGS5 - part 4 when selecting HTML5 HD (but not auto - yet).

Avatar image for glees0rz
#15 Edited by Glees0rz (53 posts) -

@aera: I was watching that only I had it stop playing 3/4 of the way through. It now seems completely random videos cannot be watched unless I choose Streaming and this is in both Chrome on my Windows 10 PC and Safari on my iPhone 6 Plus.

Avatar image for xenobytezero
#16 Edited by xenobytezero (20 posts) -

Kodi Add-On is giving me the Error Message video for everything. Unlinking and Linking didn't help.

Everything seems OK on the actual site for me, including HTML5 and HD, both subscriber and standard vids.

Avatar image for spud693
#17 Edited by spud693 (78 posts) -

Same issue, signed in with valid premium account, thus far only getting error when trying to view trackmania turbo quick look using chrome 49.0.2623.87 m

Avatar image for notthatguy
#18 Edited by notthatguy (38 posts) -

my roku channel giving error messages on all content. got a fix, please? roku2

Avatar image for radish
#19 Edited by Radish (167 posts) -

Having issues downloading and watching videos with the giant bomb ap today and getting the error video. My account is active and linked successfully.

Seems like it is only certain subscriber videos. Vinnivana Draculas Curse ep 1 is an example.

Avatar image for rick
#20 Edited by rick (506 posts) -
Avatar image for cymril
#21 Edited by Cymril (6 posts) -

I'm having this issue with Chrome, on my PC-- not even trying to download anything, just streaming the videos from the site. The premium video I was watching cut out partway through, and when I resumed it, I got the error video instead. A bit ago EVERY video gave me the error, even non-premium ones, but those appear to be working again. Streaming Premium videos is working fine in browser on my ipad, however.

Avatar image for rick
#22 Edited by rick (506 posts) -
Avatar image for cymril
#23 Edited by Cymril (6 posts) -
Avatar image for hustlerlt
#24 Edited by hustlerlt (365 posts) -

Just another person checking in about some videos not streaming. Tried watching Fortune Street TNT again a few minutes ago, neither streaming nor downloading works. Tried streaming/downloading Mario Party 9 TNT, also the same problem. The new Trackmania video works though. Am using Chrome on my PC.

Avatar image for szlifier
#25 Edited by Szlifier (1496 posts) -

@edgework: Older video URLs like v.giantbomb.com/video/something.mp4 redirect to v.giantbomb.com/people/ (404)

Tested on Persona 4 videos.

Avatar image for yosoyju
#26 Edited by YoSoyJu (17 posts) -

Using Chrome on an iPhone 6 Plus trying to play Game Tapes 02. It works on my phone, but using AirPlay to my last gen Apple TV gives me the error video.

Avatar image for somethingclever
#27 Edited by SomethingClever (458 posts) -

Reporting in as well, multiple browsers (Chrome & IE), multiple devices (cell phone, tablet, desktop PC), all trying to access site directly (no side apps or anything). Can watch videos via Streaming but nothing else. Can't download any level of quality. Seems to be any video I try. Videos I downloaded yesterday won't re-download today. Can't seem to download any of the podcasts (using BeyondPod on my phone, some configured by manually entering the RSS feed, others by searching and subscribing to the feed).

I'm subscribed through September 25, 2018 so that isn't the issue.

Just in case it was a bad cookie or temp file of some sort I cleared everything but that didn't help at all.

*edit* I think it's fixed for me. Though I did just get a 404 when I clicked into a video I just saw pop up on the front page. Looks to be gone now though so maybe I wasn't supposed to see that.

Avatar image for sleepoverking
#28 Edited by SleepoverKing (16 posts) -

Hey, I'm getting the same issues with playing/downloading videos in any fashion. Everything is showing the "This is an error" video, podcasts won't play, etc. Using Firefox on my PC.

Avatar image for biomajor09
#29 Edited by biomajor09 (39 posts) -

Yeah I am having the same difficulty as well.

Avatar image for rick
#30 Edited by rick (506 posts) -
Avatar image for d3cap1tat0r14
#32 Edited by D3cap1tat0r14 (3 posts) -

Can't watch any videos not even non subscriber ones, don't have the problem on my phone just my pc, and am subscribed for a few more months

Avatar image for rick
#33 Edited by rick (506 posts) -

@szlifier: Can you give me an actual url this is happening for?

Avatar image for szlifier
#34 Edited by Szlifier (1496 posts) -

@edgework: v.giantbomb.com/video/vf_persona4_part_04_1500.mp4

Avatar image for sleepoverking
#35 Edited by SleepoverKing (16 posts) -
Avatar image for snuffymcgee
#36 Edited by SnuffyMcGee (0 posts) -

Any updates on what is causing this?

Avatar image for rick
#37 Posted by rick (506 posts) -

@snuffymcgee: A big change in how we serve video and no matter how hard we test, believe me this was an 8 month project much of which was testing, nothing compares to the production environment when it comes to finding the edge cases. We uncovered a few problems, rolled everything back and will fix and try again on Monday. Please bear with us.

I'm sorry for any problems you guys ran into today.

Avatar image for radish
#38 Edited by Radish (167 posts) -
Avatar image for tpundsack
#39 Edited by tpundsack (15 posts) -

All my videos downloaded using RSS feeds in the Android podcasting app Doggcatcher are Jeff's error message video.... Sad times

Edit: I deleted everything and downloaded again. Seems to be working!

Avatar image for floatingyuzu
#40 Edited by floatingyuzu (20 posts) -

@edgework: Recently got Jeff's error message on my new Apple TV 4 Plex app. Since then I haven't been able to get anything from the Giant Bomb Channel. I've uninstalled the channel and deleted Application Support files on the Plex Media Server (My media server is running OS X 10.11.3) but to no avail. Currently the channel via the app or the Plex web interface has nothing.

I just realized there is an update to OS X --> 10.11.4 I'm downloading now maybe that will help.

Edit: Nope, updated and still no dice.

Avatar image for sockpuppetpseudonym
#41 Edited by SockPuppetPseudonym (6 posts) -

Giantbomb Video Buddy isn't showing any videos on iPad ("There was an error. Tap to retry"). Uninstalled-reinstalled but still the same. Current OS, I'm logged in and membership uptodate. Works fine on iPhone just not on the iPad.

Avatar image for rick
#42 Edited by rick (506 posts) -

@sockpuppetpseudonym: I don't know what to tell you. Sorry. We reverted our changes to video delivery.

Avatar image for corranhorn
#43 Edited by CorranHorn (1 posts) -

@sockpuppetpseudonym: I'm getting same thing, both Ipad and Android phone. I noticed though its only when I'm on my home wifi (comcast with a netgear nighthawk router). When I'm on 4g network on phone it works fine, tether to my phone to ipad and it works fine. No idea what would be causing it.

Avatar image for vinnie_ton
#44 Edited by Vinnie_Ton (12 posts) -

@corranhorn: I've got this exact problem. It's always worked fine until yesterday. Now I get "an error has occurred, tap to retry" when connected to my home router, but it works fine on 4G.

Avatar image for underseamanboy
#45 Edited by UnderseaManboy (24 posts) -

When downloading videos from the RSS feeds in the iOS Podcast app (iPhone 6), the download gets to the very end and then fails.

Avatar image for sockpuppetpseudonym
#46 Edited by SockPuppetPseudonym (6 posts) -

Hurrah! The Video Buddy is back up and running for me as of yesterday afternoon. I'll delete my posts in a bit so they're not clogging the place up.

Avatar image for vinnie_ton
#47 Posted by Vinnie_Ton (12 posts) -

@edgework: Hey, any idea why Video Buddy says "An error occurred, tap to retry" when I'm connected to my home WiFi network? It has always worked fine on this network until Friday/Saturday. For some reason it still works fine when I'm using mobile data. Please help!

Avatar image for nivi
#48 Posted by nivi (132 posts) -

use case 3 isn't really accounted for; i use a poscast client (and have for years, it's the only way i can reliably sync progress across all my devices) and i can't append an api key to the url of each video in the feed without mirroring the feed and altering it myself

if that's what i have to do, fine, okay, but that's not exactly a practical use case for most people

also, i just lost progress in about four different videos because my podcast client freaked out about all the videos suddenly getting way shorter

Avatar image for rick
#49 Posted by rick (506 posts) -

@nivi: Podcasts aren't effected. Only video.

Avatar image for nivi
#50 Edited by nivi (132 posts) -

@edgework: i subscribe to the video podcast feeds at http://www.giantbomb.com/feeds/