Avatar image for mason20
#1 Posted by mason20 (349 posts) -

I've encountered a issue that seems to negate my Left (shield) hand ever since I've tried the Dlc.

To explain the issue: No matter what I equip in the shield hand all it shows is the small wooden platform that is under every item but not show the item and when I would switch to said shield/item/weapon the animation would be as if I were uneqiuped but I would still have the weight of whichever shield/weapon/item i had equipped.

Now what may have caused this: I noticed that steam downloaded a gig yesterday but didn't think much of it. Got home from work today and saw today that the DLC was released and bought the season pass and checked online how to find it. Yes, I know that is cheating but after seeing the trouble that Vinny went through for DS1 ( I work 11 to sometimes 15 hours a day. Not a vaild excuse but yes, an excuse none the less..) I just wanted to know where to go. So I bought the Season Pass, loaded the game up, went to the area where you teleport to the first room with a fire in the center and a lit a torch, searched the room, and whenever I approached the main door it would just say "CLOSED" on screen. Now, with a torch in hand I quit to make sure I had the right key. I checked and it seemed like I had the key but the door couldn't open and I quit the game with a torch in hand.

So I quit and checked to see if the DLC was installed and Steam says "Yes" and followed that with the Verify integrity option in the Steam menu. Everything seemed to be okay. I started my save up and my character had a torch in hand and walked through said "CLOSED" door but as soon as I went dual handed to get rid of my torch, my character refused to bring anything out. I've reloaded at a bonfire, jumped off a cliff, let a enemy kill me, let a boss kill me, and have died from a status ailments. All I get is the Wood disk under the Left/Shield (nothing to show anything equipped just the wood disk underneath) option and the weight that the shield adds with no blocking abilities or any shield ability that I depend on as a main play style..

So... My build. should I start over? Hope the Giantbomb community braintrust could help me with my issue?

I've also tried to switch my character where they would be technically left handed but no matter what is in that left hand they refuse to be equipped with anything...

Please, I'm only a modest Lvl 130 and I'm too stubborn to learn to play with out a shield..

Avatar image for dudeglove
#2 Posted by dudeglove (12576 posts) -

Tried making another character just to check that the bug doesn't apply to all characters? Have you tried enchanting your off hand with the magic weapon spell? How about breaking the "shield" and then repairing it? There's the acid pool by Aldia's keep second bonfire, or a giant moat of the crap in Drangleic castle, or the pharros contraption right by the second bonfire in the grave of saints before the rat boss that will easily suffice. Does it apply to every left hand slot or just one of the three? Maybe try filling/emptying your item box at a bonfire, relighting a torch and manually extinguishing it (either rolling through water or just hitting left on the d-pad) to see if that might snap it out of the bug.

FWIW I find playing with a shield kind of pointless. Pump enough into adaptability and most enemies can't touch you. If you can't swap items in your off hand to a bow, just switch to throwing daggers and other projectiles. Alternatively, burn a soul vessel and respec your character to suit something two handed.