Avatar image for surge
#1 Posted by Surge (19 posts) -

I'm using Safari and right now some pages are terribly slow, while others are quite quick.  Any other impressions from other browsers or is everyone having this issue?

Avatar image for systech
#2 Posted by Systech (4190 posts) -

It's just the servers, because I am using Firefox 3 right now and it is slow. So many people are online right now.

Avatar image for schizoid
#3 Posted by Schizoid (1121 posts) -

Opera 9.5 was the fastest for me, but you can't upload images with it so it's a bit useless.

Avatar image for karmum
#4 Posted by Karmum (11515 posts) -

It is the servers, I'm using Firefox 3 on my laptop, that has excellent speed on any other website, its a tad slow here. Its not a big deal, because this is their first full day as a completed website.

Avatar image for xplodedd
#5 Posted by xplodedd (1379 posts) -

they are all slow, the servers are overloaded, the guys over at the bomb are speechless

Avatar image for banksrob
#6 Posted by banksrob (1140 posts) -

yep Firefox 3 for me sometime really quick other times really slow, IE is slower and haven't tried opera yet

Avatar image for banksrob
#7 Posted by banksrob (1140 posts) -
Miniman said:
"I'm using Firefox 2 (don't like 3 that much) and it is running very slow at times.
"
yes i dont like 3 either but cba to roll back to 2
Avatar image for nightkiller93
#8 Posted by Nightkiller93 (175 posts) -

Im currently using Firefox 2.something,it's pretty bad on some pages and others it's ok.It's going to be awesome when the servers are up to full speed.

Avatar image for blackwaterco
#9 Posted by BlackWaterCO (1685 posts) -

IE

Avatar image for blackwaterco
#10 Posted by BlackWaterCO (1685 posts) -

IE7

All day, Every Day

Avatar image for nwa
#11 Posted by NWA (29 posts) -

i'm on firefox 3 and every now and then a page won't load properly.  maybe i'll switch to safari and see how it goes.

Avatar image for americanpegasus
#12 Posted by AmericanPegasus (454 posts) -

It looks pretty good on the forums area, but the sign up was horrible, and I could edit my profile.

Avatar image for vlatko
#13 Posted by MacedoniaMafia (13 posts) -

I'm using Firefox 3 and the forums are very slow. 

The home page loads fairly quickly but overall, the whole site has a lot of slow down right now.

Avatar image for malakhii
#14 Posted by Malakhii (1444 posts) -

 on firefox 3 and it's doing ok, though chugging at certain places It's to be expected on a new website day 1 though.

Avatar image for locke
#15 Posted by Locke (335 posts) -

It's bad on every browser.

Avatar image for hamz
#16 Posted by Hamz (6899 posts) -

At the moment GB.com is crazy busy thats why its slow, plus its a new site so there is gonna be technical issues that need fixing or improving. Overall though the site is working pretty damn well, can't complain at all.

Avatar image for goodkn1ght
#17 Posted by GoodKn1ght (522 posts) -

ya, remeber guys BETA, this technically wan't a real launch

Avatar image for justaddwater
#18 Posted by Justaddwater (300 posts) -

Firefox 3 here and its hella slow, guess its just growing pains.

Avatar image for justaddwater
#19 Posted by Justaddwater (300 posts) -

Firefox 3 here and its hella slow, guess its just growing pains.

Avatar image for dualityofman
#20 Edited by dualityofman (140 posts) -

it took me forever to upload my profile picture, and the forums are going a bit slow as well, but thatll be fine pretty soon im guessing

Avatar image for deactivated-5b3f096aee80a
#21 Posted by deactivated-5b3f096aee80a (4198 posts) -

FF3; really slow. I hope they get more servers or something to fix this, its really chunky atm. :(

Avatar image for mooshu
#22 Posted by Mooshu (515 posts) -

It's running slow at the moment, certainly. But I doubt this isn't something that will be fixed in the near future.

Avatar image for deactivated-5b4a512bb9699
#23 Posted by deactivated-5b4a512bb9699 (391 posts) -

It's running slow on everything but I'd say IE is the fastest

Avatar image for rvone
#24 Posted by RVonE (5008 posts) -

I'm curious to see how long this huge traffic load will last.

Avatar image for aaron_g
#25 Posted by Aaron_G (1681 posts) -

Yeah it is just the site. In FF3 it is pretty slow. I haven't tried it yet and don't plan to in IE. Might make a go with it in Safari.

Avatar image for rowdyrob
#26 Posted by RowdyRob (221 posts) -

Things seem to have quicken (for me at least) in the past 10 minutes or so.  I'm using FF3.

Avatar image for blizzvalve
#27 Posted by blizzvalve (141 posts) -

It doesn't matter what browser you use. It's the servers because GB never expected for this site to be this huge this quickly

Avatar image for bladefire
#28 Posted by Bladefire (221 posts) -

Kinda of slow but its better than it was for a while back, all the pages load the first time now.

Avatar image for ogcartman
#29 Posted by OGCartman (4330 posts) -

Its really slow everywhere

Avatar image for 11samype
#30 Posted by 11samype (85 posts) -

I think it's slow for everyone.

Avatar image for famicommander
#31 Posted by famicommander (14 posts) -

Opera 9.5 is going fine for me. 

Avatar image for aviar
#32 Posted by Aviar (504 posts) -

This is the beta, so I'm guessing the site may run slow while they make further adjustments.  I'm using FF3 and yes it is running a little slow at times, but I am sure it will get better with time.

Avatar image for dappadizzle
#33 Posted by DappaDizzle (183 posts) -

it was crazy slow on firefox ... seems more faster on safari for me, but of course we have remember its day zero for this site to be bogged down with so many users

Avatar image for anonymouslegion
#34 Posted by AnonymousLegion (92 posts) -

Since the site went down it's been running a lot faster in FireFox 3 for me.

Avatar image for treefity350
#35 Posted by treefity350 (54 posts) -

Its a day one launch, its gonna be a little slow. Im using avant browser and varies from page to page and for some reason I cant use FF3. It wont show up, it said 500 internal server error.

Avatar image for lone_wolf
#36 Posted by Lone_Wolf (29 posts) -

Yep I'm also running Safari on my Macbook. I'd say about 75% of the time it loads quickly, but the other 25% is slower than hell >. >

Avatar image for agent_cool5
#37 Posted by Agent_Cool5 (24 posts) -

I'm using Flock 1.4 and it's pretty fast except that it can sometimes take forever to for a reply to post.

Avatar image for sdodd02
#38 Posted by sdodd02 (762 posts) -

I am using firefox 3 right now and it's going great.

Avatar image for absurd
#39 Posted by Absurd (2932 posts) -

Using Firefox and it's loading, not that fast but not that slow.

Avatar image for antipro
#40 Posted by AnTiPRO (105 posts) -

Fx3=Slow as balls....

Avatar image for kenzo287
#41 Posted by Kenzo287 (798 posts) -

*pulls out a knife* WHO SAID IE?!?!?!?! SHOW YOURSELVES! Firefox 3 is great. It's going pretty fast right now.

Avatar image for neopezz
#42 Posted by Neopezz (130 posts) -

I'm using Firefox 3 and i get the occasional blank page but that's to be expected.

Avatar image for paradigmer
#43 Posted by Paradigmer (263 posts) -

Giant Bomb needs to head down to  Good o'l Best Buy and get 200 more servers!

Avatar image for nf_2
#44 Posted by nf_2 (36 posts) -

I'm using Firefox 3 and it isn't too bad. My connection has been slower recently though....

Avatar image for nobility
#45 Posted by Nobility (299 posts) -

No browser will make a difference, give people time to get over the craze, it'll begin to settle down and people will get a quicker browsinging experience.

Avatar image for worldsfastestshrimppeeler
#46 Posted by WorldsFastestShrimpPeeler (469 posts) -

too much traffic.