New Apple TV Giantbomb app GB Fan! Now in the app store.

  • 119 results
  • 1
  • 2
  • 3
Avatar image for superpower
superpower

4

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@ev77:

No worries!

1) I’m on version 6.0 of the app.

2) I only have the basic carousels (Continue Watching, Latest, Latest Premium).

3) I actually just installed the app for the first time today. Upon initially opening the app, the icons for the menu appeared briefly before disappearing again. If I close the app fully and reopen it, the behaviour repeats and the menu disappears again.

In case it’s helpful, when the buttons have disappeared, I can actually hear myself navigating over the menu buttons and even get the the red notification of a livestream, but I can’t actually open any of the menus themselves without my workaround.

Avatar image for ev77
ev77

202

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@superpower: That is actually very helpful. I looked into it tonight and while unfortunately I wasn't able to fully reproduce the behavior I did make 2 changes that should help.

1) I did some small changes that MIGHT fix the issue of it appearing hidden for you. And more importantly
2) I made the bar slightly more transparent so you SHOULD be able to still click on the buttons and have it work (I was able to verify if the bar did get stuck in it's "hidden" state I couldn't click on the buttons). I've adjusted them so that I was able to click on them even when "hidden".

The build should hopefully get through apple review and be released sometime tomorrow afternoon. I would greatly appreciate it if you'd check out the build (version 6.1) and let me know how it goes. If you are still having the issue, let me know if you can at least still click on the buttons; and depending on how things go I can make some further changes.

And sorry for having your first experience be such an annoying bug, hopefully I get can this fixed up for you and it'll be smooth sailing going forward!

Avatar image for superpower
superpower

4

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@ev77:

Just got version 6.1 installed.

The menu bar icons still disappear upon initially opening the app, but now when I click on one, it does work and take me to the corresponding section!

Avatar image for ev77
ev77

202

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@superpower: Guess my fix didn't help with it being hidden. I think I'll add a toggle in the settings to not "hide" the buttons so you can see them better until I can find out how to reproduce it on my simulators.

Last few questions if you wouldn't mind:

1) What model Apple TV are you using?
2) What tvOS version do you have installed?
3) This only happens when you first load into the app and once you use the workaround it doesn't happen again until you restart the app? Or can you get it to become hidden after "fixing" it with the workaround?

Thanks!

Avatar image for kcin
kcin

1102

Forum Posts

9

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#105  Edited By kcin
No Caption Provided

Hey, I think I am having the same issue. I'm on the Apple TV HD (not 4K), latest gen, on tvOS 14.2, version 6.1 of the app. When I open the app, I can't scroll up to the row above Continue Watching. In the picture above, uou can also see that the very top nav row is faintly visible at the top of the screen, on top of the top-most elements (the Search icon on the top-right is most visible in this instance, as it's currently selected here.)

I noticed that there was a red Live Now notification for the Extra Life stream, but it went away very quickly. I didn't have this issue until today. I last used the app two days ago without issues.

Avatar image for superpower
superpower

4

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@ev77:

Sorry for the delay!

1) I’m on Apple TV 4K.

2) tvOS 14.2

3) This happens when opening the app from a fully closed state, not open in the background or anything. After fixing it with the workaround, it’s not an issue as long as I use the buttons in the app itself to navigate. If I were to press “Menu” on the remote to go back to the main page, the issue returns.

Thanks for your hardwork!

Avatar image for ev77
ev77

202

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@kcin@superpower: Thanks for the info, I'll see about getting a version with a setting to turn on the navigation bar so it doesn't hide; and I'll continue seeing if I can get it to reproduce on my machines. Very odd that it isn't letting you scroll above continue watching though.

Avatar image for ev77
ev77

202

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#108  Edited By ev77

So good news, I believe I was able to replicate the issue (or at least 1 of the issues) and have put in a fix. I also added the option to always show the navigation bar into the settings in case that didn't fix all the issues or if you would just prefer it not hiding.

Thanks for all the replies and info, it helped greatly!

I've submitted a build to apple for review and hopefully it'll be out and available in the app store by tomorrow afternoon/evening.

Avatar image for kcin
kcin

1102

Forum Posts

9

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Awesome! Thanks. Love the app so far.

Avatar image for kcin
kcin

1102

Forum Posts

9

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Hey @ev77, I no longer have the bug in the screenshot. Thanks!

Avatar image for ev77
ev77

202

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@kcin: That's great news!

Avatar image for hungryhot
HungryHot

1

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

I'm super late to this thread, but I just wanted to say: thank you! I've been using the official GB app since joining the community earlier this year, and while it's generally solid I'd find myself getting different glitches on a regular basis and missing some of the functionality found on the website. This seems to remedy much of this.

The main GB app struggled with the video getting super choppy for 10 seconds or so intermittently. If this remedies this or cuts down the frequency of it, I'll be super grateful.

Avatar image for ev77
ev77

202

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@hungryhot: You're welcome! And if you are talking about the stutter when you play HD videos, I found a workaround to fix the issue so it shouldn't happen with my app.

Avatar image for cheeseholidays
cheeseholidays

6

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Just a heads up, I’m still seeing stutters at HD quality. Apple TV 4K on tvOS 14.3.

Avatar image for ev77
ev77

202

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@cheeseholidays: What videos are you watching? I've been watching the alex drumming videos which run an absurdly long time (3-4 hours on some of them) and am seeing those stuttering again; but on the "shorter" videos of 2 and under hours it seems to be working alright from what I've been playing.

There is also a bug I'm working on where often times if you pause a video and then come back to it later and resume it, it will stutter at the start and "downgrade" to a lower quality but then I won't see anymore stuttering after it switches back up to HD.

But considering it was a workaround fix I wouldn't be surprised if a new tvOS release shook things up and made it more prominent again.

Avatar image for cheeseholidays
cheeseholidays

6

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@ev77: I think I was watching the new UPF. I can probably retest at some point over the holidays.

Avatar image for ev77
ev77

202

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@ev77: I think I was watching the new UPF. I can probably retest at some point over the holidays.

I've just released a new version to the app store that hopefully will help some.

I noticed that the new year's eve drumming video by alex (4.5 hrs long) was having some serious problems; I adjusted some things so it plays better but it still isn't close to perfect. Hopefully improvements will also be made for the less problematic videos. Let me know if it helps/hurts/doesn't change a thing.

Also added the ability to auto-play videos in a carousel. Auto play doesn't currently remember the carousel it was played from when resuming from the continue watching carousel; but that's something I'm looking to improve in the next version.

Avatar image for cheeseholidays
cheeseholidays

6

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Sorry I never replied. It seems to be limited to pausing and resuming videos, which you mentioned. I must've just spaced. I can easily just back out and resume and it's 100% fine.

Avatar image for ev77
ev77

202

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@cheeseholidays: No worries, I've put out 2 new releases that both try to improve video playback. Most all of the stuttering should be gone (both regular playing and after play/pause); but the tradeoff is that now sometimes the audio can drop out and won't return until you play/pause or FF/FR the video.

Audio only seems to be dropping out on me on very specific videos that are of extreme length (new years drumming video). If I notice it happening more often I'll probably try to introduce some "smarts" to the video to split the difference between dropping audio and stuttering the video.