Avatar image for jbick89
#1 Posted by jbick89 (142 posts) -
No Caption Provided

I'm not sure where else to post this. See above for an example. The fonts in forums and comment sections became blurry a week or so ago. I've checked my Chrome and Windows font settings, and I haven't been able to fix it. Giant Bomb is the only website I visit regularly where this is happening, the fonts are crisp and clear everywhere else. It's starting to drive me a little crazy, would greatly appreciate some help!

I'm using Windows 10, and Chrome Version 66.0.3359.181.

Thank you in advance

Avatar image for vdortizo
#2 Posted by vdortizo (252 posts) -

Have you tried another browser? Maybe a Chrome update broke something

Avatar image for monkeyking1969
#3 Posted by MonkeyKing1969 (7182 posts) -

It could be the resolution of you monitor or the setup of the video card to render on the monitor. Check under your Windows Control Panel for "Display Settings" and check resolutions, Magnifier tool, Adjust Cleartype, and custom DPI. It could even be changing the "Windows font" will help you, to do that in Windows 10 is a bit more hidden,. but under Control Panel look for the "Fonts" choice. I hope some of this helps.

Avatar image for flashflood_29
#4 Posted by FlashFlood_29 (4148 posts) -

Yeah, this is definitely one of those things that happens to me every now and then, but not specific to GiantBomb. It's a windows thing that has to do something with DPI scaling or ClearType, like MonkeyKing mentions. Never really narrowed it down to what causes it but I recall always get it fixed pretty quick with some tinkering.

Online
Avatar image for opusofthemagnum
#5 Posted by OpusOfTheMagnum (647 posts) -

It’s aprobably a Windows thing that happens occasionally. Try changing your resolution then changing it back and restart explorer or your computer. If that doesn’t work do the font dpi wizard thing.