steam

Avatar image for magicol_trevor
MaGicol_Trevor

15

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Edited By MaGicol_Trevor

im having sign in problems with steam again and i've tried everything, idk what to do

Avatar image for magicol_trevor
MaGicol_Trevor

15

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#1  Edited By MaGicol_Trevor

im having sign in problems with steam again and i've tried everything, idk what to do

Avatar image for pinworm45
Pinworm45

4069

Forum Posts

350

Wiki Points

0

Followers

Reviews: 0

User Lists: 1

#2  Edited By Pinworm45

mind elaborating? What problems? What errors? We can't just magically fix it from "i'm having problems"
 
Try contacting Steam Support, or the Steam Support Forums?

Avatar image for seriouslynow
SeriouslyNow

8504

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 1

#3  Edited By SeriouslyNow

Delete the clientregistry.blob file in your Steam program folder.  Then try logging into Steam again.

Avatar image for gamer_152
gamer_152

14857

Forum Posts

73675

Wiki Points

0

Followers

Reviews: 71

User Lists: 6

#4  Edited By gamer_152  Moderator

Sounds dumb but it's always the best place to start: Have you tried turning your PC off and on again?

Avatar image for nekroskop
Nekroskop

2830

Forum Posts

47

Wiki Points

0

Followers

Reviews: 0

User Lists: 2

#5  Edited By Nekroskop

This always works for me:  
Start taskmanager, shut down steam.exe, start steam again. 

Avatar image for iam3green
iam3green

14368

Forum Posts

350

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#6  Edited By iam3green

reset the router, internet to see if that works.

Avatar image for magicol_trevor
MaGicol_Trevor

15

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#7  Edited By MaGicol_Trevor

ok sorry i wasn't really specific but its right when i am signing in when i get this error message saying " could not connect to Stem network " and i have contacted steam support and they refer me back to this page  https://support.steampowered.com/kb_article.php?ref=6776-MYXU-0480 and i have already tired this before and it didn't make a difference. I have searched the internet for some time now and i haven't seen anyone who has had this problem before.

Avatar image for obiwan
obiwan

101

Forum Posts

7

Wiki Points

0

Followers

Reviews: 0

User Lists: 3

#8  Edited By obiwan

When was the last time you connected to Steam? I had the same issue like yours when I tried to connect to steam after I bought Civ 5 before which I haven't connected to Steam for several months.  I tried all the methods like what have been suggested above and by steam support but non of it worked. So, what did I do to end this plight? Great patience is needed at here. All I did was connect, re-connect, connect, re-connect, then close your steam program and restart, connect and connect again until....Steam is really got connected to steam server. What the real problem is simply you're really in a bad luck and got caught in server's traffic congestion (you know that currently Steam has a thanksgiving promotion).
  
Anyway, if you've tried several methods including  deleting  the clientregistry.blob file, then you can just stop doing whatever you've done. Just be patient and let your steam connects by itself. It will do eventually (my experience, it may take half an hour or to hours, it really depends on your luck, steam server status and your internet connection) 

Avatar image for magicol_trevor
MaGicol_Trevor

15

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#9  Edited By MaGicol_Trevor

The last time i actually signed in was about a month ago and i have been trying since but  I will try your method obiwan and if anyone else finds any other way to fix this please inform asap. thx

Avatar image for mordebir
Mordebir

169

Forum Posts

1222

Wiki Points

0

Followers

Reviews: 0

User Lists: 7

#10  Edited By Mordebir
@MaGicol_Trevor:  I had that too, thanks for the help guys!