Avatar image for ravensword
#1 Edited by ravensword (4293 posts) -

Lately I have been experiencing issues installing some digital games on my Xbox one. Specifically killer instinct and halo the master chief collection. It'll get to a certain point in the install (30 percent or 65 percent) then say the install stopped. After I restart it from where it left off it seems to do fine, but I'm still confused why some games are doing this. And if restarting to finish the install may cause some data corruption or something.

Avatar image for ravensword
#2 Posted by ravensword (4293 posts) -

I've tried power cycling several times, but it's not working

Avatar image for babychoochoo
#3 Posted by BabyChooChoo (7091 posts) -

I've had this happen to me before, but not lately. I usually just do what you did and restart the system or wait it out. I also have no idea what causes the problem either.

Avatar image for ravensword
#4 Posted by ravensword (4293 posts) -

@babychoochoo: I kinda don't know what else to do. I am worried about doing this too much because I'm worried it'll screw my external hard drive or something. Maybe if I turn off the console and let it sit for a bit?

Avatar image for ravensword
#5 Posted by ravensword (4293 posts) -

I seriously don't know what else to do. I restored the console to defaults three times now, done several power cycles, and everything else I can think of.

Avatar image for mike
#6 Edited by Mike (17991 posts) -

Try installing to internal storage, formatting your external hard drive, or trying a different hard drive.

Moderator
Avatar image for ravensword
#7 Posted by ravensword (4293 posts) -

@mike: I'm gonna try downloading to the internal drive then transferring it to the external and see if that works.

Avatar image for ravensword
#8 Posted by ravensword (4293 posts) -

@mike: BTW does formatting the hard drive cause some damage? I've done it a few times that's why I'm asking

Avatar image for mike
#9 Posted by Mike (17991 posts) -

Of course not....

Moderator
Avatar image for ravensword
#10 Posted by ravensword (4293 posts) -

@mike: good. Was worried it was something you should only do once or twice, not three or 4 like I did.

Avatar image for notnert427
#11 Posted by notnert427 (2159 posts) -

The only time I've had this issue was with Forza 6, and it was related to the external drive. My understanding is that the Xbox One will keep installing on external drives even in sleep mode, but I think my external drive shuts itself off after a certain amount of time of being plugged into a device that's "inactive", so I've had a couple of downloads "stop" overnight. I've been able to simply resume them all the next time I booted up the Xbox, except with Forza 6, I made the mistake of installing on the internal drive instead of resuming the external drive's download. After realizing that error midway through, I just let it finish installing to the internal drive, deleted the partial install on the external drive, and then moved the fully installed game to the external afterwards. Even with all this, it didn't corrupt or lose anything, and that includes my add-on stuff for buying the ridiculous Ultimate edition which could have easily gotten lost in the wash by being tied to the external hard drive install or something. The system seems set-up pretty well to handle this stuff.

Avatar image for ravensword
#12 Posted by ravensword (4293 posts) -

@notnert427: I can't seem to figure out why killer instinct and MCC won't finish installing. I formatted my external several times, I restored the console to defaults several times, and unplugged my Ethernet switch and plugged it back in.

Avatar image for ravensword
#13 Posted by ravensword (4293 posts) -

Still can't figure it out. Thinking of buying the physical copy of MCC.

Avatar image for huntad
#14 Posted by huntad (2407 posts) -

This happens to me all of the time too. I don't know how to solve this problem. Did installing it to the internal drive not work? If not, I would assume it's a connection problem from your console to the servers. I don't know which end is causing it, though.

Avatar image for vividnova
#15 Edited by vividnova (27 posts) -

@ravensword: Are you Australian? I know my ISP (iiNet) has this as an ongoing issue for the past few months. Something is wrong with the CDN they have setup with Microsoft for quota free downloads.

Avatar image for ravensword
#16 Edited by ravensword (4293 posts) -

HOLY CRAP! it finally downloaded. I guess it just finally decided to do it. No idea what I did differently. Hopefully going forward it isn't a issue.