I think I managed to bork some monitor settings that impacted performance - any suggestions?

Avatar image for rorie
#1 Posted by Rorie (4123 posts) -

I was trying to suss out some stuff with my third monitor (a plasma TV) where the picture wasn't properly sized. It was expanding beyond the borders of the monitor itself such that stuff on the edges of the screen was cut off. I fooled around with the Nvidia display settings to try to manually resize the screen to fit it, but that worked pretty wonky. It turned out I managed to fix the issue just by seating the HDMI cable in another slot on the TV, but now it seems like performance in games like WoW is significantly impacted when I play a game on my primary monitor and try to do something like watch a movie file or Netflix on the other monitors. I suspect I managed to do something while I was attempting to resize that window that's stressing out my video card? I tried to change all of the settings in these windows back to the settings that they were before but the performance is still noticeably impacted; WoW could easily run at 60fps with a movie or Netflix running, and now it's around half of that. Any idea how to revert all these settings back to the defaults? Maybe just uninstalling the drivers entirely and re-installing?

This stuff:

No Caption Provided

Staff
Avatar image for firewrkninja
#2 Posted by firewrkninja (246 posts) -

I'm really not that great at this sort of stuff, but my second monitor is an almost decade old hdtv. It only works at a lower resolution than 1920x1080. At higher resolutions it looks funky or has black bars or stuff cut off. I'd say try lowering the resolution once you restore the defaults. My TV likes 1360x768, the weirdest and most random of resolutions, but I'm sure every tv is different.

Also, hi rorie. :)

Loading Video...

Avatar image for justin258
#3 Posted by Justin258 (14373 posts) -

My third monitor is also a TV. Sometimes, if I turn my PC on without that monitor on, it will reset the refresh rate of my 144hz monitor back to the lowest it will go (60). Maybe go check that?

I have Windows 10, to do that I have to right click on Windows desktop -> display settings -> select correct monitor -> advanced display settings -> display adapter properties -> monitor tab - change refresh rate to highest it can go.

Also it's 3AM and the solution may be something much simpler.

Avatar image for dark
#4 Posted by Dark (484 posts) -

My third monitor is also a TV. Sometimes, if I turn my PC on without that monitor on, it will reset the refresh rate of my 144hz monitor back to the lowest it will go (60). Maybe go check that?

I have Windows 10, to do that I have to right click on Windows desktop -> display settings -> select correct monitor -> advanced display settings -> display adapter properties -> monitor tab - change refresh rate to highest it can go.

Also it's 3AM and the solution may be something much simpler.

Its also in the 'change resolution' option in the nvidia control panel, my screen does this on occasion and sets itself to 24hz, I would try this first.

Avatar image for bdead
#5 Posted by Bdead (264 posts) -

This is probably a refresh rate issue. You can check if its at 60 hz in the nvidia control panel under "change resolution". It could also be that the hdmi slot on your TV doesnt support 60 fps. So if you cant set the refresh rate to 60 in the control panel try another hdmi slot.

The problem you were having where the image would be cut off can be fixed in the menu of your TV. Look for an option for overscan and set it so that the image is scaled corretly.

Avatar image for bombedyermom
#6 Posted by bombedyermom (422 posts) -

I've had a similar issue when using a tv for a monitor - fixed it through the TV's settings, not the computer itself. Usually under picture settings there's an option for stretch or overscan. That's what mine was, anyway. Hope it helps!

Avatar image for stonyman65
#7 Posted by Stonyman65 (3614 posts) -

Make sure the monitor is running at 60hz, as a rule, I do everything through Windows and the monitor itself but only touch the Nvidia control panel to fine tune things.

Avatar image for dgtlty
#8 Posted by dgtlty (589 posts) -

Have you tried enabling "multiple display performance mode" under 3D settings?

Avatar image for freedom4556
#9 Edited by Freedom4556 (263 posts) -

@rorie: I can't tell if you're on Windows 10, but recently there was a forced update that hurt multi-monitor performance when playing games fullscreen on one monitor. KB3213986 was the MS knowledge base number.

Clean reinstalling the drivers sould wipe out any settings. There's an option for it nowadays in Nvidia and AMD's installers, it's usually under Custom not Express installation.

Avatar image for rethla
#10 Posted by rethla (3434 posts) -

I dunno how you had it before but when your screens are running different resolutions/refreshrates you take a huge performancehit and that might be the problem.

As mentioned before the classic problem with "the edges of the picture is outside the screen" is solved by removing overscan on your monitor. Most monitors allows you to change that but if not you are put pf luck.

Online
Avatar image for rorie
#11 Posted by Rorie (4123 posts) -

@dark said:
@justin258 said:

My third monitor is also a TV. Sometimes, if I turn my PC on without that monitor on, it will reset the refresh rate of my 144hz monitor back to the lowest it will go (60). Maybe go check that?

I have Windows 10, to do that I have to right click on Windows desktop -> display settings -> select correct monitor -> advanced display settings -> display adapter properties -> monitor tab - change refresh rate to highest it can go.

Also it's 3AM and the solution may be something much simpler.

Its also in the 'change resolution' option in the nvidia control panel, my screen does this on occasion and sets itself to 24hz, I would try this first.

Looks like this was the case; resetting up to the 60hz seemed to fix it. Thanks!

Staff

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.