Fanatec Speedster 2 steering wheel accelerator pedal not work

Avatar image for plipo
#1 Posted by PlipO (203 posts) -

I have a  Fanatec Speedster 2 steering wheel however the accelerator  pedal does not allow cars to go forward even though I can use the pedal to confirm choices when navigating the menu.
I have tried it with Need for Speed Underground and Need for Speed Most Wanted.
The button on the steering wheel which is assigned for acceleration - does work to confirm options within the menu but not to accelerate cars.
Anyone encountered similar problems ?

Avatar image for foxrs
#2 Posted by FoxRS (2 posts) -

I also have a Fanatec Speedster 2 but I didn't use it for some time now. When i got to play with it, i found the same problem as you, but with the brake pedal, which it doesn't respond.
The acceleration pedal works, even for confirmation in games menu. In Gran Turismo 3 none of the pedals were working but in the rest of my racing games only the brake didn't work. I tried every option possible but with no luck =\ 
As your question was 2 months i wished to ask you if you had found any solution to your problem, since we have similar ones. 
thank you for your time ;)

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.