My Ps4 Won't Read My New External Drive

Avatar image for giantlennonx_x
#1 Posted by GiantLennonx_x (238 posts) -

I just bought a 4tb WD external hard drive and I have the update downloaded and installed. When I plug it in the light comes on. Then when I go to devices and select usb storage device is says there's no device plugged in. :/ it's a usb 3.0 and it is a drive that seems compatible. Is there something wrong with the drive?

Avatar image for retrometal
#2 Posted by RetroMetal (457 posts) -

Try formatting it on a computer as a Master Boot Record (MBR) drive and FAT32.

Avatar image for dazzhardy
#3 Posted by DazzHardy (1244 posts) -

Posted this in another thread, but it seems relevant here too

Slight warning. I bought a Seagate 2TB USB3 Drive, and upon connecting it, was told it wasn't supported. Disconnected and re-connected, and got the same error message. Upon following the URL it gave me, it said to make sure you're inserting the USB plug fast and firm, so I tried again, as fast as I felt safe going without damaging my console, and it worked fine.

Short Version, make sure you plug it in fast.

Took me several attempts to get it to register properly.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.