PSN now only supports public non-dynamic IP adresses?

Avatar image for quipido
#1 Posted by Quipido (1572 posts) -

Appearently there has been some kind of shift im Sony's back-end infrustructure and they now require users to have a public non-dynamic IP adress. I have been offline for a week - I was fine for 18 months before that, everything worked fine. They didn't even notify me of this change - I had to contact Sony support multiple times and then my ISP, which offered me to add a clause to my contract to assign me the IP adress, which would cost me about 25% more of what I pay at the moment, every month. Am I missing something here? Is there anything I can do to resolve this other than pay more money to keep the same level of service? At the moment I am just burning my PS+ (and as I understand there are flash sales going on at the moment as well...grrr).

Avatar image for chaser324
#2 Edited by chaser324 (8691 posts) -

I find this incredibly hard to believe as it's a pretty unreasonable demand to make of your customers. Are you sure you haven't misunderstood or misinterpreted something?

I don't have a static IP and have had no issues connecting to PSN (well...except when PSN itself is having technical issues like it was this past weekend). I suppose it's possible this could just be because even dynamically assigned IPs tend to change very infrequently, but I doubt it.

I've never known of any standard consumer tier online service to require a static IP. I've only ever seen that be a requirement with business services, generally for the purpose of maintaining a very secure network - far more secure than is really reasonable to maintain on the scope of something as big as all of PSN.

Avatar image for jesus_phish
#3 Posted by Jesus_Phish (3898 posts) -

@quipido: That doesn't sound like a thing at all.

There's nothing stopping you buying things on flash sales either from PS+, you can do it online with their web store from anything with a browser.

Avatar image for drzing
#4 Posted by DrZing (256 posts) -

Virtually all consumer connections are on dynamic (but also public) IPs. These are perfectly fine as long as your firewall supports UPnP port mapping or has other ways of dealing with UDP ports on devices. I think only mobile networks might give you only a private IP or use only IPv6 but you wouldn't be crazy enough to use LTE for gaming right? There must be something else wrong. Try messing around with the UPnP service on your firewall with all logging enabled. PS3/4 will use that to get open UDP ports for peer-to-peer games. You can run the network test to check how it's working. You want it to say NAT Type 2 or Open. Can try NAT rules so a certain port range always goes to the PS. Worst case try the so-called DMZ mode just to see if it works at all. (Never leave DMZ mode enabled!) Probably many guides can be found online for your specific firewall model.

Avatar image for szlifier
#5 Posted by Szlifier (1496 posts) -

I think it has more to do with your shitty ISP blocking ports. Buying a public IP option would give you access to all ports. This is a workaround for an issue with your ISP. That's my guess, anyway.

Avatar image for quipido
#6 Edited by Quipido (1572 posts) -

Ok I am not very skilled in these things, but the Sony support in my region said directly I need a static IP adress and the ISP said they had multiple people coming to them with the very same issue and they resolve it with offering the adress as I said before, for money. I do have OPEN NAT/NAT2. I also can not connect to the store via web page - it just does not work, same as PS3/PS4, on both EU and american accounts. I managed to connect on my mobile (3g/edge) and purchase some games on the sale at least. But I can not download them.

Appearently you guys know way more about this stuff, is there any way to open up those ports locally, with my dynamic IP? I browsed my router settings, I tried to switch off the firewall, nothing helps. I also tried to look up guides on the internet but failed, there are ton of different issues with PSN and I can't find what applies to me. I even updated the firmware on my router, I made sure UPnP is turned on even though I have no clue why exactly. I am truly fucked at the moment.

EDIT: I don't even know what is going on, but I fixed it. I looked up the port range and entered it to my router, which disabled all of my internet functionality - I couln't open anything, so I deleted that entry and since then everything started working, even on consoles. What??

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.