KOTOR and Steam-Why Can't We Be Friends?

Avatar image for prettyhatemachine
prettyhatemachine

19

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#1  Edited By prettyhatemachine

Ok so I've just purchased KOTOR from Steam for £6.99...and it doesn't work
It brings up the box to say it's loading and then disappears, the little blue ring goes for about 3 seconds and then stops. And nothing happens
I've tried some the fixes (mss32.dll, operating as administrator, using it in xp which is actually worse and I now don't know how to turn off)
I also put in some driver (10.4) that I saw was supposed to make a difference but again, nothings changed. Does anyone know how to try and fix this?
 
My system is 4GB RAM
Intel i5 CPU 2.27 GHZ
Windows 7 Home Premium 
ATI Mobility Radeon HD 5470

Avatar image for meierthered
MeierTheRed

6169

Forum Posts

1701

Wiki Points

0

Followers

Reviews: 0

User Lists: 3

#2  Edited By MeierTheRed

I run it under Windows 7, with a Core i5 750. I initially had problems, but ended up getting it work after a long hassle by running the Configure tool in the KOTOR folder.  
 
Try disabling videos in that tool. 

Avatar image for mattyftm
MattyFTM

14907

Forum Posts

67403

Wiki Points

0

Followers

Reviews: 4

User Lists: 11

#3  Edited By MattyFTM  Moderator

KOTOR is riddled with compatibility issues with modern machines. I figured they would have fixed them before put it on steam, but apparently not. I think to get my disk copy working on my vista machine I had to download a program to disable one of my processor's cores, because the game sometimes encounters issues when running off a dual core machine.
 
I don't think that's the same issue you have though, because when I tried to play it, it would work for about 5-10 minutes before crashing.

Avatar image for meierthered
MeierTheRed

6169

Forum Posts

1701

Wiki Points

0

Followers

Reviews: 0

User Lists: 3

#4  Edited By MeierTheRed

Oh and also diable themes in properties.
 
These are my settings, and as i mentioned earlier, im running Windows 7 64 Bit.
 

No Caption Provided


No Caption Provided
Avatar image for prettyhatemachine
prettyhatemachine

19

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#5  Edited By prettyhatemachine

The box for resolution is just empty on mine, there's nothing to select at all. If I scan hardware it says my graphics aren't up to scratch giving me a red rating. I have Left 4 Dead 2 at max settings with no problems so its obviously capable of running KOTOR.  It still doesn't do anything from KOTOR.exe in the folder and only brings up the box when I try and access it through Steam
I don't whether to delete it and reinstall it and start the process from scratch as I've tinkered with it a little already

Avatar image for meierthered
MeierTheRed

6169

Forum Posts

1701

Wiki Points

0

Followers

Reviews: 0

User Lists: 3

#6  Edited By MeierTheRed
@prettyhatemachine:  
 
Its normal that it says your graphics aren't up to scratch, its such and old game and it doesn't recognize any new cards, so thats all fine and dandy. Try rechecking you game cache in Steam, if you replaced any files in the swkotor folder with those lame hacked ones online, that might be the reason for it. 
 
My game folder is untouched, i have added no modified files or anything. only disabled movies and dynamic themes. And it runs fine without crashing, i have a ATI card too.
Avatar image for prettyhatemachine
prettyhatemachine

19

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#7  Edited By prettyhatemachine

I'll try uninstalling and reinstalling the folder anew then and trying your method.
Hopefully with some luck it should work
I should add that my laptop is 1080p and running at 1920x1080, will that have any bearing on it?

Avatar image for meierthered
MeierTheRed

6169

Forum Posts

1701

Wiki Points

0

Followers

Reviews: 0

User Lists: 3

#8  Edited By MeierTheRed
@prettyhatemachine:  
 
My max resolution is 1920x1080 too, but KOTOR only lets you play in 1600x1200 sadly. The downside to this is that you might get a stretched image as KOTOR runs letterboxed. And since your on a laptop it will either just play fine and look right on your screen or it will stretch the image.
Avatar image for prettyhatemachine
prettyhatemachine

19

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#9  Edited By prettyhatemachine

Ok so I reinstalled so I could start from scratch and followed those configuration suggestions but nothings happened, still same problem. And I cannot get that 1600x1200 to display or any option to select for the resolution.
Can at least work from scratch on fixing it I guess. Plan B suggestions?

Avatar image for eisen
Eisen

141

Forum Posts

54

Wiki Points

0

Followers

Reviews: 0

User Lists: 4

#10  Edited By Eisen
Avatar image for sagesebas
sagesebas

2465

Forum Posts

579

Wiki Points

0

Followers

Reviews: 3

User Lists: 5

#11  Edited By sagesebas
@prettyhatemachine: welcome to the club
Avatar image for white_silhouette
White_Silhouette

518

Forum Posts

308

Wiki Points

0

Followers

Reviews: 0

User Lists: 4

#12  Edited By White_Silhouette

i would check the lucas forums as posted it will have the best solutions to your problem. . I had a weird issue where Kotor wouldn't work on my comp. Then after i installed windows 7 it worked.

Avatar image for prettyhatemachine
prettyhatemachine

19

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Cheers for the links, gonna try that 'Definitive' method listed on the Lucasforums. Fingers crossed

Avatar image for natural_deadhead
natural_deadhead

292

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 13

#14  Edited By natural_deadhead

I had the same problem. I found a fix that helps you play it in windowed mode, but you can't play it in fullscreen. It will also crash from time to time, but you will still be able to play it. I forget what site I found this in, because I copied it and put it in a word document. REMEMBER TO NEVER PUT IT IN FULLSCREEN OR IT WILL NOT WORK! 
 
 Running the game in windowed mode: Windowed mode can help resolve problems that no other solution can be found for. The game is completely playable, and the windowed mode doesn’t bother most people who are playing for the experience, and not for KOTOR’s “legendary” graphics. Go to KOTOR’s install directory and select the file swkotor.ini. Open it in Notepad and head down to the section named [Graphics Options]. From there add a new line beneath it called: AllowWindowedMode=1(no space;no period). Then look for the line called FullScreen=1 and change the 1 to 0. Or if you use windows 7, keep both at 1 and press ALT + ENTER to switch between fullscreen for standard game play, and windowed mode for the problem cut scenes or other glitches    .     .     
 
It will crash while you're on the Endar Spire, but when you're done that the crashes will be less frequent. SAVE OFTEN!
Avatar image for prettyhatemachine
prettyhatemachine

19

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@Natural_deadhead
That method didn't work on getting the game to play unfortunately. The game can't even initialise still

Avatar image for meierthered
MeierTheRed

6169

Forum Posts

1701

Wiki Points

0

Followers

Reviews: 0

User Lists: 3

#16  Edited By MeierTheRed
@prettyhatemachine said:
" Ok so I reinstalled so I could start from scratch and followed those configuration suggestions but nothings happened, still same problem. And I cannot get that 1600x1200 to display or any option to select for the resolution. Can at least work from scratch on fixing it I guess. Plan B suggestions? "
Its really weird you don't get any resolution options in the config tool. Its like it doesn't even know what the fuck to do with your graphics card. Do you have the latest display drivers and so forth.
Avatar image for prettyhatemachine
prettyhatemachine

19

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

As far as I'm aware I do have all the new drivers, laptop was bought new as of May 2010. It's just such a ridiculous pain in the ass to fix, I just wanted to play the game haha

Avatar image for yellowdartfrog
yellowdartfrog

3

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#18  Edited By yellowdartfrog
@prettyhatemachine: 
I know this is a bit late, but I just read this thread and wondered if you have solved the issue. I am interested to know what laptop you're using. It sounds like mine: Sony Vaio E Series, WIndows 7 64-bit, 4GB RAM, Intel i5 Core 2.40Ghz, ATI Mobility Radeon HD 5650. I just bought KotOR on Steam and have the same problem. I can't get it to go past the picture of the Ebon Hawk when I launch. My resolution box is similarly blank in the Configure menu. Have you found a solution? I've tried so many 'solutions'!! :)
Avatar image for vinnylegs
Vinnylegs

105

Forum Posts

1

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#19  Edited By Vinnylegs
Avatar image for phrosnite
phrosnite

3528

Forum Posts

1

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#20  Edited By phrosnite

I bought it on Steam  when it was 2.25 euro :) and had no problems playing it on Windows 7... I have an Nvidia card so... You've got RADEON. Maybe that's the problem...
 The other guys who had problems what  video card do you have?

Avatar image for tordah
Tordah

2590

Forum Posts

621

Wiki Points

0

Followers

Reviews: 0

User Lists: 11

#21  Edited By Tordah
@phrosnite said:
" I bought it on Steam  when it was 2.25 euro :) "
This. 
 
I'm running Win XP and it's been running smoothly for the 22 hours I've played it so far with the exception of one crash.
Avatar image for dtat
Dtat

1750

Forum Posts

546

Wiki Points

0

Followers

Reviews: 1

User Lists: 9

#22  Edited By Dtat

You know I have the exact same problem with ME1 on Steam. I would say Bioware just hates Steam, but Dragon Age runs like a dream!
Avatar image for yellowdartfrog
yellowdartfrog

3

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#23  Edited By yellowdartfrog
@prettyhatemachine: 
 
Ok I don't know if you are still checking this thread, and to anyone who is having the exact problem as I was, someone presented me with a solution which worked: 
 
"In the swkotor.ini , change the settings to this:
FullScreen=0
Anti Aliasing=1

Then add the line....
AllowWindowedMode=1

Change the resolution to 1024x768 (for now)" 
 
I had tried the windowed mode in the past but whoever had suggested it to me before neglected to mention the Anti Aliasing line (including the space in between Anti and Aliasing) so add all of the above. The resolution didn't make that much of a difference for me, but if you do change it, remember to change the numbers in the .ini file as well as alter your actual screen resolution. Hope this helps.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.