Steam overlay and achievements.

Avatar image for itspozer
#1 Posted by ItsPozer (253 posts) -

I been having issues with the steam overlay and achievements not popping up in games like Batman and Borderlands anyone have any idea why this is happening? my overlay button it F1 and i know it works when i try other games.

Avatar image for pr1mus
#2 Posted by pr1mus (4158 posts) -

I've had games not displaying the overlay when changing the default keys. I use the Home key and it doesn't work in Darksiders unless i revert back to the shift-tab keys.

Avatar image for mikemcn
#3 Edited by Mikemcn (8198 posts) -

Putting the overlay on the F1 key is a brilliant idea... Shift Tab is horribly inefficient.

Avatar image for crusader8463
#4 Edited by crusader8463 (14757 posts) -

Borderlands on PC is incredibly bad so anything not working on there doesn't surprise me, but Batman may be due to it using GFWL. I know that always screws up everything. If you go into the GFWL settings while playing Batman you may have Achievements turned off. I believe the GFWL overlay button is defaulted to the "Home" key, and, while I can't say for certain, I could have sworn that the Steam overlay gets turned off on GFWL games.

Avatar image for itspozer
#5 Posted by ItsPozer (253 posts) -

I got it working thanks

Avatar image for blueaniman93
#6 Posted by blueaniman93 (620 posts) -

Did you happen to solve the problem for Borderlands? I'm having the same problem with it.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.