Can't finish the traveler's quest line(spoilers maybe).

#1 Posted by MetalBaofu (1373 posts) -

I got to the point with the traveler's that I need to go into the armory in Adessa, but I can't. The game locks up on the loading screen whenever I try going into that building, and it always has. There was a previous side quest I gave up on because I couldn't go in there. Now it is preventing me from completing one of the main faction quests....really sucks.

I've tried everything I can think of to get around it...installing the game, moving the save to the cloud(that had helped with Skyrim before), etc., but nothing works. I just cannot go into that building. Was kinda curious if anyone else had this problem or something similar, so I figured I would post about it.

Oh, it's a Gamefly rental, by the way, so there is no taking it to the store to get a replacement or anything. I would just have ignore the traveler's or send it back and rent it again later, unless it decides to let me in before I send it back.

Online
#2 Posted by Kierkegaard (582 posts) -

@MetalBaofu: I expect no one's answered because, like me, they luckily didn't encounter this. That really sucks. I'd check official forums at 38 for fellow sufferers. Otherwise, watch the Travellers stuff on youtube and get on with the main quest if you haven't already. I found the Traveller's well done up until the end which is a little lack luster. I just got to Mel Senshir, though, and the main story is really starting to hit.

#3 Posted by MetalBaofu (1373 posts) -

@Kierkegaard: Yeah. I've finished the game and got it sent back to Gamefly. I tried it on my cousin's Xbox too and I still couldn't load that area....I just assume it was the disc. Everything else worked perfectly fine...just that one area was the problem. I even got every achievement except the one for the Traveler's.

Online
#4 Posted by AlexanderPato (2 posts) -

Has anyone else has been successful in opening the chest found at Fog of War blackened area. It lies between Drowned Forest and Caeled Coast. Can't say if it is a bug or something, but I can't reach it. Is there any hyper hidden route or cave to reach it.

#5 Posted by MetalBaofu (1373 posts) -

I know it's been 5 months, but I figured I would still post an update. My Xbox red ringed. I have a slim model now, so I got another copy of Amalur to try. Different copy of the game and a different Xbox. Same problem. I still can't get into that area. At this point I have to assume that the problem is my save file, somehow. As mentioned before, I can play the entire game and go in every building, except for that one. It's probably the weirdest problem I've ever ran into in a game.

Online

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.