Having trouble getting this installed...

#1 Posted by The_WolfHound (9 posts) -

It brings up something like I need a 1.000.00something. And apparently I have a bigger number. So, it seems like I need to downgrade but I was able to play the normal Medieval 2 fine.

#2 Posted by The_WolfHound (9 posts) -

Bump.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.