#1 Posted by mitchell486 (132 posts) -

Tried playing CIV V last night and almost the entire time that and I were trying to connect we kept getting disconnected and or my game would hang. Even on single player my game would hang sometimes or the video would have "stutters" or "impurities" with the menu when I was changing menus. So, you'd mouse over "Video Options" and then the other three would have grainy lines through them and such. And that meant either the game was going to crash then did a file verify on local content, 1 file was messed up (even once I had 2 files) and then if that stuttering happened again, I would sometimes try to close the game and it would close successfully but I would file verify and it still had 1 file messed up and re-downloaded it. I completely removed my 301.42 nVidia driver and then safe mode, ccleaner reg fix, re-install driver reboot kinda deal. The driver then seemed to respond better which was good and the game stayed running longer but it still had issues.

As I was heading to bed I deleted the entire local content for the game and re-downloaded the entire thing. Anything else anyone can tell us to try as to why it was stuttering at points and kept dropping that file? Or why we kept getting disconnected every few turns? Our internets on both ends seemed decent so we don't suspect that currently. Any help would be appreciated. Thanks in advance.

#2 Posted by Ravenlight (8057 posts) -

The multiplayer in Civ V is still kinda busted. I haven't had issues with disconnects like you have but every time I try multi, it's real laggy. If you have any active antivirus program or firewall set up, you could try disabling them before launching Civ V and see if that stops the disconnects.

Singleplayer, however, should run just fine. Are you running the game in DirectX 9 or 10 mode? My video card is DX10 compatible but I get weird artifacting sometimes if I run it that way. Try running the game in DX9 if you haven't already. Also check in your NVIDIA control panel and ensure that your graphics card isn't set to override game settings, there might be a conflict going on if your card is superseding the ingame options.

Good luck, duder!

#3 Posted by mitchell486 (132 posts) -

Thanks for the heads up banana-man! I appreciate that! I haven't tried D9 yet cuz it works like 75% of the time? But. That 25% is annoying as shit. Guess we'll see if the Nvidia Control Panel says its overriding anything tonight.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.