Avatar image for sparky_buzzsaw
#1 Edited by sparky_buzzsaw (7965 posts) -

I was attempting to post a review of Organ Trail: Director's Cut (specifically on the PC), and kept receiving error messages when I tried to do it directly from the game's page. When I tried to write the review using the Review link under my user information, it wouldn't post the review and asked me to "pick an object." I'm guessing this has to do with the game having multiple releases or release dates, but I'm no tech guy.

Anyone else encounter this and have a workaround? Also, any chance of there being a restoration of the user reviews feature?

Avatar image for mento
#2 Posted by mento (3732 posts) -

@ltsquigs mentioned something about reviews being attached to releases. I'd guess you have to pick one to link with your review, but I've had issues with that as well (for whatever reason I couldn't link my Knytt Underground review to a PC release, even after creating one). Meanwhile my Barkley Shut & Jam Gaiden review is trapped in a bizarre void not unlike the B-Ball Dimension because the game had no releases prior to the big switch and the database decided to throw up in its own mouth to compensate.

I get why they chose to do reviews this way: It makes a huge difference if you're reviewing a port that's known to be inferior/broken or you're playing some manner of enhanced GOTY rerelease, but it's still a pain to deal with all these issues.

Avatar image for sparky_buzzsaw
#3 Posted by sparky_buzzsaw (7965 posts) -

@mento: Selecting the release seems to be what's causing the problem. I was hoping to start reviewing one game a day, but since most of what I've got in mind has multiple releases... ugh.

Avatar image for peezmachine
#4 Posted by PeezMachine (350 posts) -

I'm having this issue with Stardrive, which only has one release. Getting the "please select a wiki object to review" message.

Avatar image for yummylee
#5 Edited by Yummylee (24646 posts) -

This is only semi-related, but does anyone know if editing your reviews still automatically removes its recommendations? As someone who is prone to making a fair few typos, I'm now locked out of heading back to gussy any problems I spot during my period of re-reading them a few dozen times. I should note that I do read over my user review before I post it, but there's always something I'll invariably miss all the same...

Avatar image for sparky_buzzsaw
#6 Edited by sparky_buzzsaw (7965 posts) -

Still having this issue. I'm going to try posting the review to the Organ Trail (non-director's cut) version, but any updates or workarounds would still be appreciated.

EDIT: Nope. Not even the vanilla Organ Trail is allowing a review. Joy!

Avatar image for slag
#7 Posted by Slag (7349 posts) -

@sparky_buzzsaw: I've read a couple complaints about this over the last couple months now basically immediately since the relaunch. AFAIK it hasn't been fixed yet.

Avatar image for sparky_buzzsaw
#8 Posted by sparky_buzzsaw (7965 posts) -

I assume this is somehow related to the lists function being broken? Is this going to be looked at during the list rebuild?