#1 Edited by Sweetz (487 posts) -

Update 5/14/13. Firefox 21 is officially out today and has H.264 enabled by default, so you can skip the steps below.

----original post follows----

Fellow Firefox users, Firefox 20 is out and finally supports H.264 video (provided you're on Win 7 or above)! This means you can finally watch Giant Bomb's HTML5 videos. I tried it out and it works absolutely fine.

For those wondering why they should use the HTML5 video player, it's because it allows very high quality (unlike the streaming player) and yet also still allows skipping ahead without being fully downloaded (unlike the progressive player).

Note that H.264 is disabled by default in FF20 (technically, it's still in testing, but it works fine). To enable:

  1. First, make sure you're on Firefox 20. Click the Firefox button -> Help -> About. If you're not on 20 this should trigger an update.
  2. Type about:config into the address bar.
  3. Say you'll be careful (i.e. click past warning message).
  4. In the search box, type foundation, you should get back one result named: media.windows-media-foundation.enabled
  5. Double click the row to switch the setting to true.
  6. Close and reopen Firefox and you're good to go.
#2 Posted by Szlifier (479 posts) -

About time. I'm sure @snide is happy about this.

The procedure is the same one I used in a Nightly a while back. This should be enabled by default, though, or at least thorugh normal settings window.

#3 Posted by SuperWristBands (2266 posts) -

Thanks for the heads up and how-to. I would have had no idea otherwise.

#4 Edited by Sweetz (487 posts) -

One thing to note, I've found after initially clicking the play button it can take an oddly long time for a video to start, sometimes upwards of a minute. However, if I click to advance the video to some spot and then back, it will start playing after just a second or two of buffering. So it appears that FF's H.264 support is not 100% trouble free yet and this is probably why it's disabled by default, but once the video is playing it's fine.

---edit---

Like Dolphin_Butter says, it turns out hitting the big play button, and then the little play button down in the loader bar works. Minor inconvenience.

#5 Edited by Dolphin_Butter (1913 posts) -

I have to click the play button twice in order for it to go, but it works. Also, hardware acceleration needs to be on, in my experience.

#6 Posted by OllyOxenFree (4970 posts) -

OH FUCK

#7 Posted by Sweetz (487 posts) -

Just an update that Firefox 21 is out on the release channel and has H.264 support enabled by default. Reminder: this is only on Windows 7 or above because Firefox uses Windows' built in H.264 decoder which is only provided with Win7 or later.

There's still the problem where you have to hit play twice to get the video to load, but they still play fine.

#8 Posted by MAGZine (435 posts) -

now all you have to do is use firefox.

#9 Posted by oknofi (7 posts) -

Single clicking on a video download link now tries to play the video in the browser from firefox 21, small annoyance I know but it kind of ignores the [ options > applications > mp4 > save automatically ] setting.

I download nearly all videos to play on my TV/PS3 so thanks to this thread, disabling [ media.windows-media-foundation.enabled ] has fixed this for me - thanks!