Newly installed FM2-A75MA-E35 motherboard - Slow Internet

#1 Posted by jeff4moso (212 posts) -

So I built my first PC over the weekend. Everything seems to be running fine, however I'm experiencing very slow internet (less than 1MBps download). I am using a wired connection and should be getting around 50MBps download. Any experienced PC folks out there that have run into this problem? Any ideas on what would cause the issue? As far as I know, I have all of the updated drivers...

#2 Edited by TyCobb (1972 posts) -

What's your adapter's speed listed as?

Open Task Manager and go to Networking. What's it showing for the connection speed? It should list 100Mbps or 1Gbps depending on what your adapter supports. If it's lower, try and re-install or update your drivers for it.

EDIT: 1MB/s download is dependent on the server you are downloading from and your connection. Your connection may be fine, but the server just isn't giving it to you fast enough. Another thing to note that your "50MBps" is actually "50Mbps". Big difference. You should not expect 50 MB/s because the most you can get is 6.25 MB/s. You also need to make sure you have a DOCSIS 3.0 modem. Otherwise you'll actually be capped around 25 Mbps.

#3 Posted by jeff4moso (212 posts) -

@tycobb: OK thanks, I'll try that when I get home. I'm all set with the modem so that shouldn't be the issue.

#4 Posted by Korwin (2871 posts) -

These two things are not related.

#5 Edited by TyCobb (1972 posts) -

@jeff4moso: But understand that 1MB/s is not slow and probably just your download source not giving it to you faster. You can have 1Gbps internet and still get downloads of only 500KB/s if the server sucks or throttles the speeds.

Give this site a spin to test your internet. http://testmy.net/

#6 Posted by jeff4moso (212 posts) -

@korwin: Thanks for the help? Was it really worth responding with that?

#7 Posted by jeff4moso (212 posts) -

@tycobb: I miss typed...I am getting less than 1Mbps. It's definitely slow. Was trying to download a small game on Steam (<500 MB) and it said it would take like 4 days. Something is definitely wrong.

#8 Edited by Budwyzer (586 posts) -

http://www.speedtest.net/

This would definitely help to be sure. But yea, Steam servers shouldn't be putting you at 1Mbps. Then again, your store page would be slow as tits at that speed as well. So I'm wondering how long it took you to even get to the download button.

#9 Posted by jeff4moso (212 posts) -

@budwyzer: I used speedtest.net. That's how I saw what my download was. I also ran the test while Steam was closed so that isn't putting me down.

#10 Edited by TyCobb (1972 posts) -

@tycobb: I miss typed...I am getting less than 1Mbps. It's definitely slow. Was trying to download a small game on Steam (<500 MB) and it said it would take like 4 days. Something is definitely wrong.

Make sure you don't accidentally have your download rate capped in Steam's settings. It would also be wise to check what server you have selected to download from. I know mine likes to default to Los Angeles from time to time for some odd reason when there's a server located only 40 miles away from me.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.