#1 Edited by dr_mantas (1844 posts) -

First of all specs, I'm running windows 7, firefox 20 (Aurora, because it has HTML5 compatability), and my monitor resolution is 1650*1050 (why this is important you will see later).

If you (the devs) could take the minute it takes to read this, it would be appreciated :)

I know you must be busy with many issues that came up with the new site launch, but I'm still writing this down, at least for later reference.

Issue #1 - The video player does this weird stuttering thing (again in HTML5 and HD), where it seemingly loads, stops, loads, stops, loads little sub-second parts of the video, loading and stopping when it loads (as in not loading at least a couple of seconds of video in advance). Which I guess creates this weird stutter. Could be related to the new video provider (I think I heard something about a new video provider?)

Issue #2 - The video player (in HTML5 and HD setting) doesn't properly go fullscreen. There are spaces at the top and bottom, where the page stays visible - and it's the actual webpage, because if I press down (for example), you can see the page scroll down. It was an issue during the Seaserpent beta, and it probably didn't get addressed. It might have something to do with resolution (I think it attempts to go fullscreen, but because my resolution is 16:10, not the nigh ubiquitous 16:9, it gets confused).

These are probably not issues that would be bothersome with the youtube player, but because there is QUITE a lot of premium content (which is WONDERFUL), the youtube player isn't always an option.

Thanks for your time, you magnificent bastards that you are ;)

#2 Posted by dr_mantas (1844 posts) -

I reiterate, this is the same stuttering bug people experience, and it seemingly affects many browsers and systems.

It most likely is due to the video streaming provider, which I believe they have changed.

#3 Edited by alexisg (382 posts) -

Thanks for the detailed bug report. It super helps when we start tackling the new Firefox. Unfortunately we just can't support a pre beta developers only build right now. It is changing too quickly for us to keep with it. Video was not working at all last week on that browser and now it seemingly is without us changing anything. I am really excited about h264 video on Firefox and we will support it once it gets closer to a Release Candidate.

Video performance will get better soon or should. We moved our videos to akimai which actually support larger than 2GB files much better than amazon was. Site performance in general is slowing us down but engineers are on it.

Thanks again.

Staff