#1 Edited by deano546 (184 posts) -

For the past 2 or 3 weeks the schedule has been pretty off for me on all of my computers, here's what it looks like right now: http://i.imgur.com/0qUSsIT.png

Clearing cache and cookies doesn't fix it. I think its off by 4 days, 3 hours and 39 minutes, but I could be off by an hour or two either way.

Also I'm in Ireland so my timezone is GMT +00 if that helps.

#2 Posted by Rorie (2987 posts) -

@deano546: Yeah, we've had some issues with this lately. Unfortunately it's difficult to verify this stuff since it tracks location based on IP and displays the time based on that, and we're obviously all on a San Francisco IP. But I'll check on the status of the bug I filed. Sorry for the trouble!

Staff
#3 Posted by Fuwano (157 posts) -

For myself, I'd be cool with an option to just see the times in PST or GMT and doing the math in my head. Not a huge complaint, but it kind of bums me out when I try to catch a live stream and it's not for another hour (as just happened for me). Not trying to whine.

#4 Posted by CrimsonClown (134 posts) -

I've been having the same issue. Interestingly, I'm also in Ireland.

#5 Posted by AMyggen (3635 posts) -

Works here in Norway.

Online
#6 Posted by Chaser324 (6744 posts) -

I'm EST, and it's working fine for me.

Moderator
#7 Posted by Tampler (17 posts) -

I've been having the same issue. Interestingly, I'm also in Ireland.

Ireland here too....Same problem.

#8 Posted by deano546 (184 posts) -
#9 Posted by Rorie (2987 posts) -

@deano546: Still in the bug queue, alas. Best we can tell it normally just screws up when our system can't match your IP to a timezone correctly. A bit difficult for us to test since we're all on the same IP, but I know it's still on the list of stuff to fix.

Staff
#10 Edited by CrimsonClown (134 posts) -

It's working properly again for me, no more crazy times. Yay!