#1 Edited by GiroMindTricks (63 posts) -

Today I upgraded to a new motherboard. Switching all components across went as smoothly as these things could. The problem was that once it was all together it wouldn't POST. It had power and the fans were going, so I tried swapping out the RAM.

Now here's the bit that I find weird. It won't POST with only my corsair sticks installed, but will with some value sticks I have spare. It will also POST with the value (in the primary slots) and the corsair sticks. I've tried every possible combination and this is the only one that works.

I know the corsair sticks aren't officially supported according to the website, but they should at least work at stock speeds right? Plus they work with the value ram installed as well!

I've tested the RAM and it came back without any problems, so I'm at a loss.

If anyone has solved this issue before or has some idea what is going on I'd appreciate the input.

Specs:-

Motherboard : ASRock 990FX Extreme 3

RAM: 2 x 4GB Corsair Vengeance LP & 2 x 4GB Value RAM

#2 Posted by GiroMindTricks (63 posts) -

Could a mod please move this back to the PC forum? It was originally, but once I edited it it was moved to general discussion.

#3 Posted by Zelyre (1175 posts) -

I've seen some DDR3 modules with certain voltage requirements that some boards don't support.

Do your budget ram modules have memory chips on both sides of the PCB? Does the Corsair have memory chips only on one side?

Your motherboard may not support the higher density memory modules.

#4 Edited by GiroMindTricks (63 posts) -

@zelyre: The value sticks have chips on both sides of the PCB, but I can't see under the heat spreader on the corsair sticks. I have tried setting the voltage and latency to settings I know the corsair sticks are compatible with while the value sticks are installed and then swapping them over, but no joy. Plus when the corsair sticks are installed the BIOS loads up a profile to overclock the RAM to 1600Mhz so it must recognise them in some way.

Also if the board didn't support the corsair modules, surely they wouldn't work at all or am I wrong?

#5 Posted by Zelyre (1175 posts) -

So the BIOS shows 16 gigs of ram with those 4 modules in place?

Really strange. I don't have any experience with AMD chipsets as of late, I'm not sure what kind of limitations it has.

#6 Edited by GiroMindTricks (63 posts) -

@zelyre: Yeah, at the moment I have both sets (4x4GB=16GB) installed and set at 1600MHz. I'm completely baffled as to why the corsair sticks only work when the value sticks are installed as well.

#7 Posted by Zelyre (1175 posts) -

Other thing I'd try is taking the memory off auto settings and set the memory timing/voltage settings to the cheap ram setting. Then remove the cheap sticks and see if it posts then.