Help starting Gmod.

#1 Posted by Afro_Stevens (79 posts) -

I bought Gmod yesterday, and every time I try to run it, the game gets to the loading screen and then I get a message that says hl2.exe has stopped working. 
Now, I haven't had this problem so much with TF2 or Zombie Master, which is why I thought that this was strange. 
I've also restarted Steam, and uninstalled and reinstalled the game twice. 
Hopefully someone can help me with this.

#2 Edited by Breadfan (6590 posts) -
@Afro_Stevens Dude I had the same thing happen to me when I bought it a few weeks ago. 
 
I did what the email below said and it works fine now.
 

 Hi - this sometimes means that your computer isn't good enough to run it - or (more likely) you need to update your graphics card drivers.

There's a guide to updating your drivers here:

https://support.steampowered.

If the problem persists even after updating the graphics card drivers, a few people have reported success by adding -dxlevel 80 to the command line.

To do this, right click Garry's Mod in steam and go to Properties. In the window that pops up click the "Set Launch Options" button at the bottom. Now in that box, type "-dxlevel 80" exactly as shown (without the quotes).    

Hope this helps 
 
EDIT:  Adding the command line is what helped me get the game working
#3 Posted by Afro_Stevens (79 posts) -

Thanks a bunch. 
I did the -dxlevel 80 option, and it works great now. 
Much appreciated, man.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.