No Audio from HDMI

#1 Posted by Razorlution (186 posts) -

Hi duders, I was curious if someone could help me out with some ideas on how to fix my problem. I just got m,y new computer built by a friend and all went smooth. I am trying to get sound from an HDMI but to no avail. My drivers are all up to date, and I am lost at what to do next. My GPU is a Sapphire 7870 and my monitor is a Samsung 7 series 750 24". Please pass on any ideas you may have, its unfortunate that I have this great PC to enjoy but no sound.

Thanks again in advance!

#2 Edited by Sergio (2261 posts) -

Just in case, check your sound panel to make sure the sound output is set to the AMD HDMI Output instead of speakers, or whatever your on-board sound chip is.

Edit: Also, I don't know if this has since been fixed, but I remember updating to the latest drivers, and afterwards, this setting would always default to the wrong thing, and I had to reset it to AMD HDMI Output after every reboot. I eventually reverted to an older driver and haven't tried updating since.

Edit 2: On my set up I have AMD HDMI Output and Realtek HDMI Output. The latter is from my motherboard, so I have the former enabled and set as the default device.

#3 Edited by Ammut (23 posts) -

Right click volume icon on bottom right -> playback devices -> Digital Audio (HDMI)

Or something with a similar label.

Right click that and set it as default device.

Huzzah?

#4 Posted by Razorlution (186 posts) -

I do not know how to check my sound panel....sorry. Also, when I click on the speaker thing in the corner, there is nothing that allows me to set my digital audio (HDMI) to default. I can go through the control panel and access it, but it appears grey and will not allow me to set it as the default device. I have tried different hdmi cords and they are not the problem. My Digital Audio says it is not plugged in, was that during the build or something else??

#5 Edited by Devildoll (912 posts) -

@Razorlution:

could you take a screenshot of the playback tab? ( rightclick the little cornerspeaker , and then hit "playback devices" (i think?) to get there )

#6 Posted by Sergio (2261 posts) -

@Razorlution: That's the panel I'm talking about. I'm on Windows 7 and go to Control Panel, then Hardware and Sound, then Sound. On the Playback tab you should have a list of "devices." Take a screenshot as said so we know what you are working with. I don't think I had to do anything in the BIOS when I built my machine, but it's been a couple of years, so don't really remember.

The only times I've had similar issues, they were always related to drivers.

#7 Posted by Razorlution (186 posts) -

So I had a problem with the first monitor, no audio at all. Returned it for a new one, I am able to get audio from the audio jack, and getting video from dvi. But I am still unsure why I am unable to get sound when it is hooked up by hdmi.

#8 Posted by PillClinton (3297 posts) -

@Razorlution: Is it a straight HDMI cable (i.e. not going through any adapters or anything)? And not to insult your intelligence, but is there an option in the monitor's menus to turn audio/speakers on?

#9 Posted by cartvader (142 posts) -

1 - You may want to reinstall the drivers, choose custom install not express and make sure that you are installing the HDMI audio drivers.

2 - make sure you are connected via HDMI to your computer when you boot the system.

3 - Go into your control panel and check your sound devices as suggested. Make sure that is set to AMD HDMI.

#10 Posted by Razorlution (186 posts) -

I have checked the drivers, will triple check them later, the Hdmi is the only cable in when I boot the computer up. I am ok with the way it is working, but just weird.

I appreciate all the feedback on helping me out here!

#11 Edited by Devildoll (912 posts) -

okay, if i'm getting this straight,

You want to run a hdmi cable from your graphics card to your PC monitor, which is not a TV, and the sound is supposed to come out where?

based on the semi precise model name you mentioned in the original post, i tried to track down the monitor so i could read the manual.

does it look like this?

-

-

-

-

I did a ctrl F on sound and speakers etc in the manual, and all i could find was talk about you setting the hdmi mode to "av", and then plugging in a stereo jack for sound.

but whats the point? just hook your headphones straight up to your pc, bypass the monitor, if you got speakers, ditto.

#12 Edited by mordukai (7185 posts) -

@Razorlution:I think I know what causing your problem. When you install your catalyst drivers make sure it's the 12.1 version because for some reason every version after 12.1 causes the HDMI to appear grayed out as if the device is malfunctioning.

Just make sure that completely uninstall the drivers you have on now. DO NOT install it on top of your existing driver.

Go to Programs and Features and make sure to completely uninstall the Catalyst version you have.

#13 Posted by Duder_Me (299 posts) -

Right click on the Windows volume icon on the task bar, click on playback devices, and right click to enable your HDMI audio, and right click to disable the default one if needed.

#14 Posted by Razorlution (186 posts) -
@mordukai That driver does not have my hoy listed for the 7000 series tho
#15 Posted by Razorlution (186 posts) -

Gpu I mean, not hoy lol

#16 Posted by mordukai (7185 posts) -

@Razorlution: Try the 12.2 then.

#17 Posted by Razorlution (186 posts) -

So, solved the issue, was a Realtek driver that was the problem, and I am glad to say that everything is working perfectly!! Thank you for all the advice duders! All the best!

#18 Posted by larebz (1 posts) -

I know this is an old thread so sorry for bringing it back firstly but had to add a bit of info here seeing as this was one of the top results in google when i was searching for this perticular problem.

I went through hell for 2 days trying to get the HDMI audio working on my 7870, it was showing ATI HMDI Audio in playback devices but i could never enable it as 'Set as default device' was always greyed out. After much frustration howeverl i finally got it working and this is how:

1. Download and install the newest CCC if you haven't already.

2. Uninstall both Realtek drivers from control panel. Restart.

3. It seems silly but install both the drivers you just uninstalled again from here (the default and the ATI HDMI Audio Device driver): http://www.realtek.com.tw/downloads/downloadsCheck.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false. Restart.

4. Now you want to uninstall just the ATI HDMI Audio Device. Restart.

5. After the reboot windows will now automatically download it's own driver which is compatible with the 7870.

Now you should be able to go to playback devices and enable and set hdmi audio as default now. I hope this helps anyone having this problem in the future.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.