Wired 360 Controller Not working with SR3? Help!

#1 Posted by STORMP00PER (90 posts) -

hey everyone,

So just got SR3 while its 50% on steam, got it installed and it won't let me play with a wired 360 controller. I've done some googling but cannot see anything that would fix the problem - has anyone got any solutions for this? I have a wireless mouse and keyboard plugged in via usb too no other input devices. HELP!

Many thanks

#2 Posted by Demoskinos (17103 posts) -

@STORMP00PER: Not saying your stupid or anything but you installed the proper drivers and whatnot for the 360 controller right? Cause Saints Row should instantly detect a controller and change all the HUD elements to be 360 buttons instead of keyboard stuff.

#3 Posted by AlisterCat (6422 posts) -

Is it wired and not just wireless with a plug & play? Check drivers and such. Make sure controller is enabled, some games require it to be selected first (can't remember for Saints Row 3).

#4 Edited by MrKlorox (11142 posts) -

I just tested mine and you're right, it totally doesn't... EXCEPT when the intro videos are playing. It detects that A is being pressed and skips one each time, but doesn't work in the menus. Wireless works fine. Might have to emulate one with x360ce since I know my wired PS3 controller works when emulating a wireless 360 controller. I'll do more tests then report back.
edit: okay, after disabling my PPJoy virtual joystick (it has a low VID hardware number so certain games try to detect it first), the wired 360 controller suddenly worked the next time I started the game. Button icons and everything. Do you have any other controllers or joysticks installed? What's listed when you type "joy.cpl" in the RUN box (WIN+R keys)?

#5 Posted by STORMP00PER (90 posts) -

sup, yeah its an official microsoft wired controller, drivers etc are there, its plug and play and i've recently been ploughing through my steam copy of skyrim with it, for whatever reason SR3 just doesnt recognise it?

Kinda bummed I've been listening to all the great stuff that Ryan and the guys have been saying about it for months now. For me these type of games just doesn't feel great with the keyboard and mouse - sigh.....

#6 Edited by MrKlorox (11142 posts) -

So does that mean there are no other devices listed in the Game Controllers panel? Have you tried rebooting after installing the game and or gamepad drivers for the first time? Can you skip the intro videos with the A button when you launch the game?

#7 Posted by STORMP00PER (90 posts) -

@MrKlorox: thanks for checking that man, no other input devices installed, I do have a wacom installed (not plugged in currently) would those drivers have an effect?

#8 Posted by STORMP00PER (90 posts) -

@MrKlorox: hmm weird, i re-read your post and checked the joy.cpl thing and there is nothing listed - should i be seeing the xbox controller in there?

#9 Posted by WilltheMagicAsian (1548 posts) -

@STORMP00PER said:

@MrKlorox: hmm weird, i re-read your post and checked the joy.cpl thing and there is nothing listed - should i be seeing the xbox controller in there?

If it's plugged in, yeah. Try installing the 360 Accessories Softwaredunno if it'll work, but might as well give it a try.

#10 Edited by MrKlorox (11142 posts) -
@STORMP00PER: Yes, you should see "Controller (XBOX 360 For Windows)". It doesn't seem to be installed correctly. Do you see any icons with a yellow triangle in the Human Interface Devices section of the Device Manager ( devmgmt.msc in the RUN box)?
edit: regardless, @WilltheMagicAsian's suggestion is probably the solution.
#11 Posted by BonOrbitz (2416 posts) -

@STORMP00PER: When I bought SR3 back in December I was able to immediately play with a wired 360 controller. Recently I bought a wireless 360 controller and it works as well. When I run joy.cpl and activate my wireless controller, it appears in the listing. I'm not familiar with the control option settings in SR3, so maybe something can be tweaked there?

#12 Posted by STORMP00PER (90 posts) -

@WilltheMagicAsian: downloaded that software and i can now hit the start button on the desktop (super useful lol) still nothing showing up in joy.cpl?

#13 Posted by MrKlorox (11142 posts) -
@STORMP00PER: Was there anything listed with a little yellow triangle inside the icon in the HID part of the device manager?
#14 Posted by STORMP00PER (90 posts) -

@MrKlorox: theres one for a EIO driver but thats been there for donkeys, i looked into it a while ago and is just ome random windows bug i believe

#15 Posted by MrKlorox (11142 posts) -
@STORMP00PER: If you plug it into another USB port, it should try to install the device again for that port. Close joy.cpl and reopen it after you make the switch and see if anything shows up.
#16 Posted by STORMP00PER (90 posts) -

@MrKlorox: nada, nope, nothing doing - so strange, had a look on the official thq forums (which are a pretty rubbish) and the only fix they had was for removing any Razor drivers

#17 Edited by MrKlorox (11142 posts) -
@STORMP00PER: I dunno man. I'm pretty stumped myself. My last suggestion would be to scour that list of HID devices (redundant I know) in the manager for something that seems like it could be blocking the 360 controller. BTW, is there any listing for a "HID-compliant game controller" at all? Or anything else in that list with the Hardware ID "HID\VID_045E&PID_028E&IG_08"? (right click the device, click properties, select the Details tab, choose the second property in the drop down list, "Hardware Ids" and look at the first line) 
Might as well give uninstalling the drivers for that wacom a shot.

If it's letting the guide button go through (something only microsoft programs are able to use) then something has to be in the device manager. And once you find that thing, you should be able to try to force the installation of the drivers.
#18 Posted by Demoskinos (17103 posts) -

Yeah, I went and actually manually installed drivers for mine. It never worked properly for me until I did that.

#19 Posted by STORMP00PER (90 posts) -

I'll have to give some of that a go the marra and see thanks to everyone for the suggestions - god bless giant bomb!

#20 Posted by adam_thuraisingam (2 posts) -

I had almost the exact same problem. My wired 360 controller was only detected by SR3 when skipping the intro videos.

Anyone looking for a solution: the only way I can get SR3 to detect the controller on the menu screen/in-game is to uninstall my Razer Nostromo. Not ideal, but it works. Must be something to do with Razer drivers in general - I'll report it on the SR3 website.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.