Is your XB1X slow?

Avatar image for haneybd87
#1 Edited by haneybd87 (396 posts) -

I was surprised to hear on the Bombcast that they were having problems with their XB1X’s dashboards being so slow. Just the other day I was thinking to myself how it’s so quick and snappy using the dashboard on the X. It’s fast right from a cold boot and from suspend and both my drives are almost full. The Games and Apps app is also pretty fast too. Is your XB1X also slow or is it quick and snappy like mine is?

Avatar image for mems1224
#2 Posted by mems1224 (2508 posts) -

mine is mostly fine. occasionally it takes like 5 seconds to show all my games in the my games and apps section but nothing egregious. its by no means a great dashboard but its fine.

Avatar image for ntm
#3 Edited by NTM (11843 posts) -

It can be slow, yeah. It reminds me of a thread I made relatively recently about how you may want to plug the console into the wall as opposed to a surge protector. That said, I had it in the wall for two weeks or so and it slowed down, so I just went back to putting it in the surge protector. Also, if the system slows after a while, I always restart the system and it fixes it for some time. The games that I can install have recently (as of two days ago) been taking some time to load, unfortunately.

Avatar image for frytup
#4 Edited by frytup (1325 posts) -

I'd call it hitchy rather than slow, but either way the Xbox UI team needs to put more time into performance improvements.

Avatar image for crazybagman
#5 Posted by CrazyBagMan (1663 posts) -

Yeah, I was kinda surprised how extreme they made it sound. Mine is totally fine 90% of the time.

Avatar image for xanadu
#6 Posted by xanadu (2046 posts) -

Yeah its totally fine for me

Avatar image for the_greg
#8 Posted by The_Greg (543 posts) -

@ntm said:

It can be slow, yeah. It reminds me of a thread I made relatively recently about how you may want to plug the console into the wall as opposed to a surge protector. That said, I had it in the wall for two weeks or so and it slowed down, so I just went back to putting it in the surge protector. Also, if the system slows after a while, I always restart the system and it fixes it for some time. The games that I can install have recently (as of two days ago) been taking some time to load, unfortunately.

This. Mine was a little slow on the dashboard, never really thought much about it until I saw the thread about putting it into wall. I haven't seen any slow-down since then.

Avatar image for tatsuyarr
#9 Posted by tatsuyarr (247 posts) -

It's alright even if it isn't perfect. Restarting it can improve things sometimes. I wonder if the fact that I have more than 200 installed games slows it down or if it has nothing to do with it. Anyway my biggest grudge after the mandatory update before starting a game (non existant either on switch nor PS4) is the fact that sometimes a game won't even start and then a message indicating it took too long to start the game (What does that even mean!? it never happens on PS4 or Switch) is displayed, and then I try again and it works. It's baffling. If it wasn't for my achievements (I still like those) I would have given up this console entirely by now.

Avatar image for yesiamaduck
#10 Posted by Yesiamaduck (2554 posts) -

Dont plug it into a plug strip woth a surge protector it causes dashboard lag on boot up

Avatar image for nutter
#11 Posted by nutter (2185 posts) -

It’s slower than it was when I first got it, and slower than it should be, but I wouldn’t classify it as straight-up slow.

Avatar image for thepanzini
#12 Posted by ThePanzini (740 posts) -

I found little to no difference between the Xbox One and 1X the dash isn't slow but it stutters and hangs frequently it's never really felt great.

Avatar image for liquiddragon
#13 Posted by liquiddragon (3443 posts) -

This is still an issue even on the beefy-er hardware? That’s kinda sad and pathetic.

Avatar image for haneybd87
#14 Edited by haneybd87 (396 posts) -

Seem to be getting mixed answers here. I wonder what could be causing some people’s dashboard to be slow and others not? Something to do with internet connection? Older models slower for some reason?

Avatar image for sethmode
#15 Posted by SethMode (2039 posts) -

I love the system, but for whatever reason the dash runs like shit. I've read some delightful horror stories about memory failure and whatnot, and while I don't know if that's my issue, it still runs like poop regularly and almost always after a hard reboot (which it did itself in the night).