I must be doing something wrong (spoilers)

#1 Edited by Daveyo520 (6678 posts) -

So, I am near the end of the game on the very last stretch of Ilos. This has nothing to do with enimes or how hard combat is. I need to drive down a ramp to get to the conduit in under 40 seconds. IT IS IMPOSSIBLE! I have tried so so so many times and can never make it in time. The Mako is just nor dast enough or I need just 5 more seconds. I hate driving the Mako and the fact I need to be perfect at it to contiue the game is so wrong. I don't know why no one has complained about this before. So that leads me to believe I am not really doing what I am suppsed to be. I think I need to touch the conguit in time, but it is just not possible. Any advice would be greatly apreciatted. 
 
EDIT: Got it. I had to turn down my settings to make the game run faster.
#2 Posted by hedfone (1751 posts) -

hmm never had a problem with that

#3 Posted by ArchScabby (5809 posts) -

Are you shooting the enemies?  Because you don't need to.  Just drive straight at the portal or whatever it is, don't worry about anything else.

#4 Edited by Jeust (10541 posts) -

Forget the enemies, despite some fighting back, and just step on it to the conduit. 

#5 Edited by Daveyo520 (6678 posts) -
@Jeust:
@ArchScabby:

I do, trust me. I just drive straight ahead as fast as it can go. But I  never make it. Like it's not even close. I drive down the thing straight at the conduit, but time expires before I can get there.
#6 Posted by HitmanAgent47 (8576 posts) -

Yeah like what everyone said, just drive directly to the conduit.

#7 Posted by Link06 (19 posts) -

Make sure you go straight to it following the river at first. Don't slow down or swerve. I've done it on my first attempt on insanity.

#8 Edited by CL60 (16906 posts) -

Really? I have never actually lost going to the Conduit. I just  take the path straight down and I make it in time. Even on Insanity I made it my first try.

#9 Posted by Daveyo520 (6678 posts) -
@CL60:
I don't know what it is, it just doesn't do it. It is supposed to be easy.  
 
Maybe the PC version just hates me....
#10 Posted by RandomInternetUser (6789 posts) -

That's extremely weird... I just held down the W key if I remember correctly.

#11 Posted by Daveyo520 (6678 posts) -
@xobballox:
So have I...... I dont stop for anything.
#12 Posted by Jeust (10541 posts) -
@Daveyo520 said:
" @xobballox: So have I...... I dont stop for anything. "
hummm maybe you should reload the last save before running to the conduit. You might have a bug there.
#13 Posted by mazik765 (2315 posts) -

I don't know what the problem is if you're just driving straight there. I have played ME1 4 times through (once on Insanity) and have always had ~10 seconds to spare upon reaching the conduit :/
 
Maybe it's a bug? If so you might want to email Bioware tech support :/

#14 Posted by Daveyo520 (6678 posts) -
@Jeust:
@mazik765:

It probably is, I'll reload a save. Yah, I shouldn't be strappd for time.
#15 Posted by Daveyo520 (6678 posts) -
@Jeust:
Okay, I went back and got to the part and it still isn't enough time. Did you get 40 seconds? Also did it stop you before going down too say a few words than show a cutscene?
#16 Edited by Bigandtasty (3202 posts) -

I'm thinking maybe it's something to do with visual effects; if there is a "frame limiter" or "vertical sync" try turning it off. I could not complete a mission in GTA: San Andreas without turning off the frame limiter. 
 
It could also be due to a weak video card; several people have reported this problem around the internet and stated that lowering the visual effects (resolution, texture quality, etc.) helped.

#17 Posted by ReyGitano (2467 posts) -
@Daveyo520 said:
" @Jeust: Okay, I went back and got to the part and it still isn't enough time. Did you get 40 seconds? Also did it stop you before going down too say a few words than show a cutscene? "
Just saw a youtube video of the PC version. Cutscene, then 40 seconds. You should be able to make it in 30.
#18 Edited by Daveyo520 (6678 posts) -
@SlashseveN303: It was my own computer's fault because it is not that good.
@Bigandtasty:
I think you are right. It worked when I turned all my setting down. 

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.