Uplay AC3 Keyboard, Mouse and Controller input not working

#1 Edited by UlquioKani (1179 posts) -

I purchased AC3 a few weeks ago in the Uplay sale and at the time, it was working fine. I started it up today to play again and it is not taking any sort of input I give it. The mouse stays at the top left hand side of the screen, the keyboard doesn't work and neither does the controller. I've tried looking up info on this and the only thread I found didn't have any sort of solution. I've tried re installing but this hasn't helped. The only change to my PC since the last time I played it was a Graphics card driver update.

I'd love to know if anyone else has this problem. I'd also appreciate if anyone with a Uplay version of the game test to see if they have the same problem with the game now.

Thanks for the help.

Online

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.